1

I justed installed Debian Jessie and was happy to see (or hear) that my Creative Sound Core 3D (as onboard chip on my Gigabyte GA-X99-Gaming 7 WIFI mainboard) worked out of the box when trying to play some music...

But actually it's the only thing that works. Neither the front-panel connectors function nor does the microphone (whether front or back panel).

So I started googling about what I can do ...

The following news article (dating 2012) at least states that in general there should be drivers available:

"Linux Support Finally For Creative Sound Core3D"

Precising my search I found those two more or less same articles about sound driver setup on Debian/Ubuntu:

"Front panel audio headphones/microphone"

"Soundkarten konfigurieren › HDA" (german)

So I tried to follow the steps described there ...

~$ cat /proc/asound/modules 
 0 snd_hda_intel
 1 snd_hda_intel

and ...

~$ aplay -l
**** Liste der Hardware-Geräte (PLAYBACK) ****
Karte 0: PCH [HDA Intel PCH], Gerät 0: CA0132 Analog [CA0132 Analog]
  Sub-Geräte: 0/1
  Sub-Gerät #0: subdevice #0
Karte 0: PCH [HDA Intel PCH], Gerät 1: CA0132 Digital [CA0132 Digital]
  Sub-Geräte: 1/1
  Sub-Gerät #0: subdevice #0

Though not really knowing anything about ALSA and or Linux/Debian sound driver architecture I assumed that with this information I will be able to solve my problem.

But when I wanted to lookup the exact model at ALSA configuration file I noticed that the relevant files were missing on my machine:

/usr/share/doc/alsa-base/driver/ALSA-Configuration.txt.gz
/usr/share/doc/alsa-base/driver/HD-Audio-Models.txt.gz

As even more the configuration file /etc/modprobe.d/alsa-base.conf is missing I assumed that I just need to install the respective packages. But that's not the case as it seems:

~$ sudo apt-get install alsa-base 
Paketlisten werden gelesen... Fertig
Abhängigkeitsbaum wird aufgebaut.       
Statusinformationen werden eingelesen.... Fertig
alsa-base ist schon die neueste Version.
0 aktualisiert, 0 neu installiert, 0 zu entfernen und 0 nicht aktualisiert.

What can I do now? Is ALSA even the right thing to look for?

To give some more details the below screenshots of my audio configuration:

Outputs Inputs

Interestingly enough when connecting the mic to the back-panel I at least can see that it detects the connection but it does capture anything.

  • Try the latest kernel. If that does not work, show the output of alsa-info. – CL. May 21 '15 at 8:47

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.