0

The machine was running Debian wheezy and was recently upgraded to Jessie. Everything has worked fine for some time. However, after a reboot today the desktop won't load.

/var/log/messages shows gnome-shell: segfault at 0 error 4 in libupower-glib.so.3.0.0

I have tried reinstalling gnome-session, gdm3, libupower.

(Sorry about the formatting, I'm on a phone.)

  • Sounds like a bug. Report it? (As a temporary workaround, try a plain window manager like twm.) – Anko May 20 '15 at 20:05
  • I did file a bug on this and recent updates seem to have fixed the problem (things that rely on libupower are working again) though i'm not sure if my bug report mattered. – user1794469 Feb 7 '16 at 22:00
1

This may probably a bug, you should report it...and the solution.. Temporary install another desktop and waiting for reply, if you have ability, compile it yourself. PS: first you can find your system installed glib version, then compile the same version of glib replace stock one, have a try...

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.