1

I am facing a rather strange problem. I have a 32 bit qmake binary placed at a very deep path. So for ease of use I created a link using

ln -s /complicated/path/to/qmake ~/qmake

I am running a 64 bit machine. So I installed 32 bit libraries. The binary is failing to load when I run

~/qmake

it reports an error saying no such file or directory when the file is there. but runs smoothly when I use 32 bit laoder

/lib/ld-linux.so.2 ~/qmake

The more insteresting thing here is. If I run

/lib/ld-linux.so.2 /complicated/path/to/qmake

it displays an error e.g

qmake: @ɇ�: QRU�4�������̀]ZY�: H: Error 18446744073564424934

but as I have already mentioned the binary gets loaded using the symbolic link

so I have 2 problems here.

  1. Why I have to explicitly mention the loader with the application
  2. Why error with the complete path ... when the symbolic link is running fine ?
12
  • Just my guess concerning question #2: perhaps it is a problem of the path exceeding max length in Linux? Please do a grep -e PATH_MAX -e NAME_MAX /usr/include/linux/limits.h and compare with your "very deep path" length. Not sure if this is the cause -- logically, this should also concern the symlink. – dr_ May 20 '15 at 8:03
  • PATH_MAX is 4096 chars ... The path is not that deep – theadnangondal May 20 '15 at 8:06
  • What about the complicated path itself, are there any special characters ? – Sergiy Kolodyazhnyy May 20 '15 at 8:17
  • @Serg yes there are ... but If that is the case should the symbolic link work or nor ? – theadnangondal May 20 '15 at 8:20
  • Can you provide the output of ldd ~/qmake? – chaos May 20 '15 at 8:27

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.