12

My problem is, that my Debian installation shows a grey screen on start up and boots into a console, instead into gnome.

When I start X manually with startx everything starts fine, so the DE seems to be functioning.

12

The program where you type your user name and password in a graphical environment, and that logs you into a graphical session, is called a display manager. You need to install a display manager. On Debian, if you install any of the display manager packages then one of them will be started at boot time.

Any of the packages that provide the x-display-manager virtual package will do. As of Debian jessie, that's gdm3 (Gnome), kdm (KDE), lightdm (lightweight but themable), slim (lightweight but themable), wdm (lightweight but themable, oldish), xdm (old-style, bare-bones). You don't have to use a display manager that matches your desktop environment. If in doubt, pick lightdm.

  • i have gdm3 installer, and write in cmd gmd3 start no succes but write in cmd startx load gnome succes, but is in boot the os no running gnome – Ymil May 19 '15 at 21:33
  • @LautaroLinquiman What happens when you run service gdm3 start? Copy-paste the output. – Gilles 'SO- stop being evil' May 19 '15 at 21:36
  • Sorry, then install ligthdm success ok. Thank yo! :) – Ymil May 20 '15 at 0:14
5

I was also confused by this problem for a long time. Reading the documentation from Debian wiki, at last, I finally found a way out.

# systemctl status gdm

# systemctl start gdm

and then I can access GUI again. Reference:

3

First of all GNOME is already there, but by default it is off.

To reset your login manager so that it runs gnome at boot up, do (as superuser)

update-rc.d -f gdm3 defaults

Or you can re-install and select the proper options

You can install the GUI easily:

apt-get install gnome
  • I'm test your solutions but don´t result. – Ymil May 19 '15 at 21:29
  • Hope you got your solution from @Gilles – Shaheen Iquebal May 20 '15 at 6:15
0

Well i had GDM3, in Debian SID after updating to unstable package GDM didnt work,

after a few google i found the solution, removing the .ICEauthority file and then configuring GDM3 to use only X11 from /etc/gdm3/something.conf

-2

Sometimes this happens if u run out of HD space if u can free some space using "CD" command to navigate through ur directories nd use the "rm 'file'" command to delete the file that can give u some free space then use the shutdown command to exit nd start the PC agin nd it will boot to the GUI. Pis ay

  • 2
    Please write standard English. – thb Dec 13 '16 at 19:00

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.