2

I installed Opensuse13.2 using dual boot on my system that originally had windows 8.1. If I was using UEFI boot option then my computer automatically logged onto the windows OS.

So I was using legacy boot option which automatically logged into Opensuse and when I wanted to log into windows I changed it from the boot menu at the start up.

The Grub boot loader was not showing windows8.1 at the startup as an option. In an attempt to correct this I followed a tutorial and used the following command.

bcdedit /set {bootmgr} path \EFI\opensuse\shim.efi

After doing this now I can not log into my windows installation. It says that no boot option can be found.

I am logged into my linux installation and have access to my windows OS files. Is there some way that I can manually edit some file to correct this?

6
  • 1
    Could you link to the tutorial you followed, please? – user86969 May 19 '15 at 16:05
  • @Nasha tweakhound.com/2014/11/13/… – Syed Moez May 19 '15 at 19:48
  • @Nasha Can you please help. Can I some how add windows option to grub boot loader? – Syed Moez May 19 '15 at 21:00
  • I am using GRUB-EFI and it is giving me option of loading into windows boot manager. But I am getting the following error: file path: /ACPI(a0341d0,0)/PCI(2,1f)/Sata(0,0,0)/HD(1,800,fa000,16a082cf58cba94b,2,2)/File(\EFI\Microsoft\Boot)/File(bootmgfw.efi)/EndEntire error: cannot load image. – Syed Moez May 19 '15 at 23:11
  • I am totally agnostic of the Dark Side of the [U]EFI (too much a hassle to my taste) but looking at what you described I guess Grub expects some /EFI/Microsoft/Boot directory tree on the boot partition. I'm not sure though. Can you check? – user86969 May 20 '15 at 19:39
1

You seem to have spoiled your windows bootloader for now but that might still be fixable by installing openSUSE with UEFI bootloader and not CSM/Legacy one (so that there's actually an /EFI/opensuse/shim.efi on the EFI System Partition). There's nothing GRUB can do to load Windows if its own bootloader is misinstructed as per some careless tutorial.

Don't hurry. And better yet, read this first. A very short version is that your bootloader is not going to boot any UEFI OS if it's booted in Legacy mode, and installing UEFI bootloader is not possible in Legacy mode either.

So install openSUSE in UEFI mode (there's usually a difference when you choose your flash drive, might be "UEFI:" prefix or like that) and try booting Windows via the resulting EFI GRUB -- that would likely end up loading GRUB again though. I'm not a Windows expert so not in position to advice you on reverting that bcdedit though; might be worth it to backup the data and scrap it to start over again with more care (and just switch the OS boot order in your system's firmware settings so that Linux -- that is, GRUB -- starts by default).

PS: there's a nice boot manager called Refind in case firmware misses a boot menu, its author also publishes micro ISO with it and it's included in my ALT Linux Rescue as well (just boot it and select the rightmost boot target to scan disks for OSes).

5
  • 1
    Thanks. I installed rEFInd and was able to log into my windows. Then I fixed windows boot loader by using start up recovery for windows 8.1. I installed Linux using UEFI boot option and now I am getting Grub EFI with both windows and Opensuse option. – Syed Moez May 21 '15 at 20:34
  • I sitll have one question. The reason that I changed my boot option into legacy was that while using UEFI option, GRUB boot loader was not loading opensuse setup. So I changed to legacy and loaded it using that and ran into troubles. Later on I was able to run GRUB Boot loader even with UEFI option. I think this is because I turned off secure boot option with UEFI, but I am not sure. Can you please help me with this? for future issue? – Syed Moez May 21 '15 at 20:36
  • Hmm... clarify please: the media would boot, you would see its GRUB and select installation option, and what would happen next? SB option would have blocked GRUB loading if it was at fault (although there might be an issue with signed kernel image but that seems unlikely given that they signed GRUB just fine). Well, try turning RestrictedBoot(tm) on and see if openSUSE stops loading (shouldn't but I've seen that with distros carrying two signatures on shim, all of us but Ubuntu do that)... Glad to hear you're up and running, anyways :-) – Michael Shigorin May 23 '15 at 8:19
  • Thanks. The reason why I installed Linux in Legacy boot mode in the first place was that when I tried installing it in UEFI mode, The media did not started the boot. It showed me a list of commands that I could type and did not knew how to start the installation. Below is a link. Every thing is working now I installed Linux again in UEFI mode but I am not sure what I changed, may be I switched off secure boot. Just wanted to know so that I don not run into trouble in future. unix.stackexchange.com/questions/203334/… – Syed Moez May 24 '15 at 3:38
  • Maybe -- you can check that by switching it on and seeing if GRUB still boots... wish the firmware wouldn't appear "smart" enough to ditch the "wrong" entry from boot list though; if you try that, I'd be thankful if you also check the above referenced rescue image to see if Refind boots off it with your particular firmware with SB on (but still better to stay on the safe side if another reinstallation warrants a lot of hassle to you) -- I've implemented UEFI support in ALT so sort of interested for it to work for the normal people. – Michael Shigorin May 25 '15 at 7:17

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.