1

Occasionally, I can increase kmix's volume to its maximum (using the volume hotkeys), but the sound is still very quiet. I can open up alsamixer, and see Master at ~8%, even though kmix's volume is 100%. If I change kmix's volume, I can see similar changes in Master, but only up to ~8% maximum.

I can manually increase alsamixer's Master. This fixes the problem for a reasonable amount of time; changing kmix's volume results in similar changes in Master up to its maximum. However this fix seems to revert in a seemingly random and non-reproducible way (perhaps after a restart?).

Is there a way to ensure that setting kmix to maximum results in alsamixer at maximum?

I'm not sure if it's related, but when I change the volume in kmix, alsamixer's PCM varies seemingly randomly from 100 to 98 and 99, and Headphone goes from 0 (at 0% kmix) to 55 (at 5% kmix) to 100 (≥10% kmix). As stated above, Master increases with changes in kmix.

Plasma 5.3 (but I think I saw it in KDE 4) in Arch Linux

  • This appears to be a problem with PulseAudio's juggling of multiple mixer controls. Try asking on the PA mailing list. – CL. May 19 '15 at 8:53
  • Thanks @CL. I'll give this question a few more days, then try the mailing list. – Sparhawk May 20 '15 at 6:32

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.