1

Months ago I saw a guy running commands from a small, text-box-like window, showing nothing else other than the text-box for you to write the command. Such text-box would popup by pressing some keyboard shortcut. Specifically, from what I remember, he was using Lubuntu, and mostly opening apps (like Chrome, Audacious, etc.).

I've never found anything like it, and I've searched considerably for it.

Is it a known extension for lxde or did he most probably create it by himself?

Thanks everyone!

4
  • 2
    what about alt+f2?
    – Mateo
    May 19 '15 at 1:18
  • nothing happened :/
    – Lucas F
    May 19 '15 at 1:22
  • Also asked at askubuntu.com/questions/625440 .
    – JdeBP
    May 19 '15 at 5:16
  • Cross posting is not allowed on U&L, and chit-chat like "Thanks everyone" is inappropriate according to the help->tour
    – Anthon
    May 19 '15 at 10:55
2

Try pressing Alt+F2.

I'm not totally sure about this though, as when I search Alt+F2 in LXDE on Google there seem to be a fair number of results about a bug. Not sure if those still apply.

However, this is the shortcut that worked for me last time I used LXDE.

3
0

While Ubuntu's default AltF2 is pretty useful, I've noticed in the comments that it does not work for you. An alternative run dialog that you can use is bbrun. This run dialog is originally for black box desktop environment, but can still be used elsewhere. Install it using sudo apt-get install bbrun. Once you do, run it in terminal with nohup bbrun & and you should have a star-like icon appear on your desktop. It's pretty small, so you might wanna look around the edges of your screen.

enter image description here

Clicking on that star icon brings up the run dialog

Alternativelly, you could bind a shortcut to the following script:

#!/bin/sh
set -x
COMMAND=$( zenity --entry --text="What to run?" )

/bin/sh -c "$COMMAND" &
3
  • I appreciate the suggestion. But I could indeed make Alt+F2 work! I'll put the link as a comment in my question.
    – Lucas F
    May 19 '15 at 1:52
  • @Serg One of your images is not quite there.... May 19 '15 at 1:52
  • @somethingSomething yeah, I tried it twice - didn't load. I'll just get rid of it May 19 '15 at 1:53

Not the answer you're looking for? Browse other questions tagged or ask your own question.