2

I am relatively new to Linux and I have assembled a raspberry PI 2 model B and I'm relatively inexperienced with Linux. I have tinkered in the past with SUSE and want to start doing it again. I have managed to get it up and going using the Ubuntu-Mate installation from raspberrypi.org; in fact, I'm typing this from it as I am writing this. My question is about getting openSUSE going, since it is my preference.

The source I am trying to use is the 13.1 version from this link: https://en.opensuse.org/HCL:Raspberry_Pi

The instructions for writing the image specify:

xzcat [image].raw.xz | dd bs=4M of=/dev/sdX; sync

which is all very new to me. Per the directions, I checked lsblk to find out the name of the SD card I wish to write to. I should also mention that since the raspberrypi only has one microSD slot, I am using a generic USB to microSD reader along with a class 2 8gig microsd. Now, I know this is a slow card and if this openSUSE version works well, I have a 32gig class 10 microSD I will write to.

I opened the only terminal in Ubuntu-mate using ctrl-alt-t and jumped to my downloads directory using cd ~/Downloads since this is where i have saved the downloaded image, called openSUSE-13.1-ARM-JeOS-raspberrypi.armv7l-1.12.1-Build38.15.raw.xz. Additionally, after downloading it, I shortened the name to help ensure everything is typed correctly.

I then entered this in the terminal window:

sudo xzcat openSUSE.raw.xz | dd bs=4M of=/dev/sda; sync

and I received this error:

dd: failed to open ‘/dev/sda’: Permission denied

I also tried pointing to sda1 and received the same error message. If I check lsblk, the terminal outputs this:

NAME        MAJ:MIN RM  SIZE RO TYPE MOUNTPOINT

sda           8:0    1  7.4G  0 disk 

└─sda1        8:1    1  7.4G  0 part /media/joseph/SUSE

The last item I should mention is that the microSD has been formatted to FAT32 using my Windows box and only has 1 partition as seen above. I gave it the volume name suse for simplification. As of now, I am stuck and really wish to get this working. What am I missing or doing wrong?

5
  • Good afternoon, and thank you for posting a reply. I am looking forward to giving this a try but i wanted to report the result of some tinkering first as it may lend to another possible cause. Following the previous result, the access denied response got me thinking so i checked with a few technicians at work and they pointed me to do the following; to which i am doing in real time while posting the result; May 20, 2015 at 18:34
  • ls -l | grep sda brw-rw---- 1 root disk 8, 0 May 20 11:26 sda brw-rw---- 1 root disk 8, 1 May 20 11:26 sda1 brw-rw---- 1 root disk 8, 2 May 20 11:26 sda2 which i believe means only gives directory access so i ran a sudo chmod 777 to change the bits to world privileges resulting in ls -l | grep sda brwxrwxrwx 1 root disk 8, 0 May 20 11:26 sda brwxrwxrwx 1 root disk 8, 1 May 20 11:26 sda1 brwxrwxrwx 1 root disk 8, 2 May 20 11:26 sda2 May 20, 2015 at 18:37
  • Running you post suggestion renders xzcat ~/Downloads/openSUSE-13.1-ARM-JeOS-raspberrypi.armv7l-1.12.1-Build38.15.raw.xz | sudo dd bs=4M of=/dev/sda; sync 0+77901 records in 0+77901 records out 1019215872 bytes (1.0 GB) copied, 247.51 s, 4.1 MB/s May 20, 2015 at 18:48
  • Im going to see if this image will boot. i will back shortly to say ya or na May 20, 2015 at 18:49
  • I'm sad to report that image was not working and the raspberry PI would not boot from it. Is it possible there is some other issue? May 20, 2015 at 18:54

3 Answers 3

1

Just do sudo su to get into a root shell.

Then do xzcat openSUSE.raw.xz > /dev/sda1.

1
  • This is the solution to the given error message. The problem was that only the xzcat command got executed as root but not the dd command. Opening a root shell by sudo su solves this. One could still do the dd command, though.
    – Ned64
    Aug 18, 2019 at 10:23
0

The first thing that sticks out in my mind is your sudo command.

From my understanding of sudo, it by default takes in one program. When you make a pipe you're saying take the output of this program and put it in another. In other words, you've only ran sudo on xzcat.

So you should do: xzcat ~/Downloads/openSUSE-13.1-ARM-JeOS-raspberrypi.armv7l-1.12.1-Build38.15.raw.xz | sudo dd bs=4M of=/dev/sda; sync

In all honesty, I'd just do:

unxz --keep ~/Downloads/openSUSE-13.1-ARM-JeOS-raspberrypi.armv7l-1.12.1-Build38.15.raw.xz; sudo dd if=~/Downloads/openSUSE-13.1-ARM-JeOS-raspberrypi.armv7l-1.12.1-Build38.15.raw of=/dev/sda

However, I'm weird like that and you might not have the storage space to do so.

0

As stated in : https://en.opensuse.org/HCL:Raspberry_Pi2

As root extract the image onto your SD-Card (replace sdX with the device name of your SD-Card). WARNING: all previous data on the SD-Card will be lost.

I had the same problem sudo simply won't work you must login as root and it will work !

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .