1

My network consists of a router which acts as a dhcp server. Connected to one of its ethernet ports is a unmanaged switch which in turn has all my machines connected to it via ethernet.

On this network I have a central "file server" running Windows 7.

I created some shares on it and I can access them from any other Windows machine on my network without any problems. The shares are stable and always accessible.

The result is very different though when I try to connect from my Linux Mint or Ubuntu machines.

Sometimes I can access the shares and sometimes not without changing any configuration whatsoever. It literally just drops the connection to the shares at any time and then it's not visible in the file browser anymore.

When this happens I can still ping the "file server" and get a response without any issues as well as connect via rdp.

After restarting the samba services via the terminal as well as the Workstation service on the "file server" the result stays the same and there is still no visibility of the shares.

So it is definitely not the connection to the "file server" that is dropping but the connection to the Samba Server seems to be faulty/erratic.

I did some research and followed guide on guide on this and it all points to adding properties and settings to the smb.conf file which I tried to infinity without any success.

It seems to work again if I restart both the file server and the Linux machine but then after a while it disappears again.

I also turned off the firewall on both ends but that also did not resolve the issue.

What I can't understand is why this works and then breaks and then works again without me touching the keyboard?

How can I troubleshoot this to get to the root cause of the problem?

  • What's the output of smbclient -L [server IP]? – Erathiel May 18 '15 at 14:45

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.