1

I dual booted Kali next to Windows7 and after a succesfull install I rebooted to not find an option to use Kali instead of Win7 in the BIOS.

After having done some research I found out that Win7 has a tendency to uninstall GRUB. So looking into that I rebooted using my live usb with kali on it and tried to solve my problem by trying to reinstall GRUB using the explanation here ,and adjusted the sda3 to sda6 since this is where I have kali installed on my harddrive: https://forums.kali.org/showthread.php?20559-How-To-Repair-Kali-Linux-Grub-With-Kali-Linux-Live-Cd-Dual-Boot-With-Windows-7

root@kali:~# mount /dev/sda6 /mnt
root@kali:~# mount --bind /dev /mnt/dev
root@kali:~# mount --bind /dev/pts /mnt/dev/pts
root@kali:~# mount --bind /proc /mnt/proc
root@kali:~# mount --bind /sys /mnt/sys
root@kali:~# chroot /mnt
root@kali:/# grub-install /dev/sda
Installation finished. No error reported.
root@kali:/# update-grub
Generating grub.cfg ...
Found background image: /usr/share/images/desktop-base/desktop-grub.png
Found linux image: /boot/vmlinuz-3.18.0-kali3-amd64
Found initrd image: /boot/initrd.img-3.18.0-kali3-amd64
  No volume groups found
Found Windows 7 (loader) on /dev/sda3
Found Windows Recovery Environment (loader) on /dev/sda4
done
root@kali:/# exit
exit
root@kali:~# umount /mnt/dev/pts
root@kali:~# umount /mnt/dev
root@kali:~# umount /mnt/proc
root@kali:~# umount /mnt/sys
root@kali:~# umount /mnt

I remove the live usb and reboot my computer while holding shift but it goes back to the windows bootloader.

Any idea on what I am doing wrong?

  • After reboot you need to update the grub to add WIndows partition (per your link): os-prober update-grubHave you done this already? – ryekayo May 18 '15 at 13:08
  • No I hadn't . I tried it now but I got this: bash: os-prober: command not found – BURNS May 18 '15 at 13:13
  • Try sudo apt-get install os-prober – ryekayo May 18 '15 at 13:15
  • Ok ,that worked. Now I got this after having to sudo apt-get install grub: root@kali:~# update-grub Searching for GRUB installation directory ... No GRUB directory found. To create a template run 'mkdir /boot/grub' first. To install grub, install it manually or try the 'grub-install' command. ### Warning, grub-install is used to change your MBR. ### – BURNS May 18 '15 at 13:22
  • Just create the directory. That seems more painless than doing a grub-install... – ryekayo May 18 '15 at 13:23

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.