4

I seem to be unable to automount nfsv4 shares in FreeBSD 10.1.

All of my mounting information is stored in an LDAP database and the shares are on a NFSv4 server.

I've gotten the mapping right so that if I do automout -L (shown below) I get the correct mapping; however, I can't seem to see where I would pass in -o nfsv4.

/home/user nfs:/user # indirect map referenced at +auto.home:1

If I edit /etc/autofs/include to try and pass in an option there, autofs doesn't seem to understand what to do with that information.

Any ideas on what else to try?

0

If you can't put them into the map entry, or auto_master, just put them on automount and automountd command line, like this: 'automountd -o nfsv4'. Or just add "-o nfsv4" to automount_flags and automountd_flags in /etc/rc.conf.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.