1

My computer have dual boot (Windows 8.1 and Elementary OS Freya - Ubuntu 14.04). Today, After installing updates on my windows partition Elementary OS loaded into a black screen. I've already encountered problems with my nvidia driver before, so I've tried to enter the terminal (ctl+alt+f1/7) and re-install the nvidia drivers.

sudo apt-get purge nvidia*

But then I got the error message apt-get syntax error "(" unexpected

I've tried to enter recovery mode and repair dpkg, but it seems dpkg was corrupted somehow.

I'm fairly new to Linux, and I'm having hard time diagnosing the problem (not to mention, Solve it). is it the nvidia driver? dpkg? or maybe something else (or all combined?)

Any kind of help will be highly appreciated.

  • First try sudo apt-get clean and then sudo apt-get update and tell us if this fixes the problem. – shivams May 17 '15 at 15:54
  • Thank you for your comment. unfortunately it didn't helped. I've also just now re installed Elementary OS. – shultz May 17 '15 at 17:32
0

Try using:

sudo apt-get purge nvidia\*

instead.

  • Unfortunately I still get the error apt-get syntax error "(" unexpected. – shultz May 17 '15 at 14:55

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.