1

I've always found USB very flaky. I've experienced lots of random freezes (needing hard resets) when for instance I accidentally unplug a drive before unmounting. Drives would only sometimes automatically mount and most of the time I had to manually told it to go ahead and mount. Drives would take very long to mount. It's always been a frustrating mess I found.

Installing Xubuntu 15.04, it's gotten worse. I now can not at all mount my 4TB USB drive any more. It consistently totally freezes my system. The clock's seconds hand stops going. Caps-lock light doesn't respond anymore. Can't switch to a tty. It 100% freezes. Every time.

Now, I could have a bad USB hub, because it is pretty much the cheapest I found through Ebay. It does USB 3.0 and never seems to work with USB 2.0 drives (it reverts to USB 1.1 then it seems). I also find USB 3 cables very badly designed. When you wriggle the connected plug a bit up and down, it immediately develops a bit of play room. I find the 3.0 plugs the kind of quality of crappy connectors one might find at a Dollar Store or something like that.

I've had problem with multiple cables, multiple drives, and two hubs, and also directly without a hub, and two motherboards, over the years. There's always something up with the whole USB drive thing. Am I the only one that finds USB flaky (been for years, still not fixed)? Sorry if I'm not sounding very constructive here, but I'm very frustrated at this point. Again, I can't move my files from one drive to another, and again I can't put on home movies for visitors that stopped by our place. Again I'm let down by technology, and again it's USB.

I'm willing to send/donate my USB hub if need be. Regardless of if/what hardware is flaky, if that's what it is, in my opinion, there is absolutely no excuse for a system to completely lock up. Getting errors is one thing, but things grinding to a halt is not right.

I don't know where to start to diagnose this. I suppose copy pasting the last signs of life before the lock up would help...

May 16 20:39:01 q kernel: [   51.797792] usb 2-1.3: new SuperSpeed USB device number 4 using xhci_hcd
May 16 20:39:01 q kernel: [   51.814128] usb 2-1.3: New USB device found, idVendor=0bc2, idProduct=3312
May 16 20:39:01 q kernel: [   51.814131] usb 2-1.3: New USB device strings: Mfr=1, Product=2, SerialNumber=3
May 16 20:39:01 q kernel: [   51.814133] usb 2-1.3: Product: Expansion Desk
May 16 20:39:01 q kernel: [   51.814135] usb 2-1.3: Manufacturer: Seagate 
May 16 20:39:01 q kernel: [   51.814136] usb 2-1.3: SerialNumber: NA4N09H6
May 16 20:39:01 q kernel: [   51.814858] scsi host8: uas
May 16 20:39:01 q kernel: [   51.815656] scsi 8:0:0:0: Direct-Access     Seagate  Expansion Desk   0739 PQ: 0 ANSI: 6
May 16 20:39:01 q mtp-probe: checking bus 2, device 4: "/sys/devices/pci0000:00/0000:00:07.0/0000:03:00.0/usb2/2-1/2-1.3"
May 16 20:39:01 q mtp-probe: bus: 2, device: 4 was not an MTP device
May 16 20:39:01 q kernel: [   51.816610] sd 8:0:0:0: Attached scsi generic sg4 type 0
May 16 20:39:01 q kernel: [   51.867739] sd 8:0:0:0: [sdd] Spinning up disk...
May 16 20:39:11 q kernel: [   57.292668] ......ready
May 16 20:39:11 q kernel: [   62.605638] sd 8:0:0:0: [sdd] 976754645 4096-byte logical blocks: (4.00 TB/3.63 TiB)
May 16 20:39:11 q kernel: [   62.606455] sd 8:0:0:0: [sdd] Write Protect is off
May 16 20:39:11 q kernel: [   62.606459] sd 8:0:0:0: [sdd] Mode Sense: 2b 00 10 08
May 16 20:39:11 q kernel: [   62.607310] sd 8:0:0:0: [sdd] Write cache: enabled, read cache: enabled, supports DPO and FUA
May 16 20:39:15 q kernel: [   65.771218] general protection fault: 0000 [#1] SMP 
May 16 20:39:15 q kernel: [   65.771233] Modules linked in: cfg80211 snd_hda_codec_hdmi joydev nouveau snd_hda_codec_realtek snd_hda_codec_generic snd_hda_intel snd_hda_controller snd_hda_codec snd_hwdep snd_seq_midi snd_seq_midi_event kvm_amd kvm serio_raw k10temp snd_rawmidi edac_core edac_mce_amd snd_pcm snd_seq mxm_wmi video snd_seq_device ttm snd_timer drm_kms_helper drm snd i2c_piix4 i2c_algo_bit soundcore shpchp wmi 8250_fintek mac_hid parport_pc ppdev lp parport autofs4 pata_acpi hid_generic usbhid hid uas usb_storage firewire_ohci psmouse firewire_core ahci crc_itu_t r8169 pata_atiixp libahci mii
May 16 20:39:15 q kernel: [   65.771303] CPU: 2 PID: 2424 Comm: panel-13-cpugra Not tainted 3.19.0-15-generic #15-Ubuntu
May 16 20:39:15 q kernel: [   65.771309] Hardware name: Gigabyte Technology Co., Ltd. GA-MA770T-UD3P/GA-MA770T-UD3P, BIOS F7 04/14/2010
May 16 20:39:15 q kernel: [   65.771315] task: ffff88041a5b09d0 ti: ffff88041c774000 task.ti: ffff88041c774000
May 16 20:39:15 q kernel: [   65.771320] RIP: May 16 20:40:44 q rsyslogd: [origin software="rsyslogd" swVersion="7.4.4" x-pid="735" x-info="http://www.rsyslog.com"] start
1

What you need to do is isolate the faulty component. It might be the operating system, but it also might be the USB cable, the USB hub, the USB port, and so on. Work your way through these steps; if you see a behavior change you've probably identified the responsible component.

  1. Try connecting the drive to a different port on the hub.
  2. Try connecting the drive without the hub in between it and the computer.
  3. Try connecting the drive to a different USB port on the computer.
  4. Try connecting the drive using a new USB cable.
  5. Try connecting the drive to your computer while it is running on the live-CD Linux distros to test against a different Linux version.
  6. Try connecting the drive to a different physical computer running Linux.
  • 1) also locks up 2) also locks up 3) I have 2 USB 3.0 ports, both cause a lock up 4) I tried 2 cables. Both lock up. – Mike May 17 '15 at 14:37
  • 5) This I have not tried yet. Don't have that handy at the moment. 6) Don't have any other computer with a USB 3.0 port around. --- I did an upgrade, which included a kernel update. Still locks up. This is the worst USB bug I've yet encountered. I've never had a bug free USB setup since I've switched to Ubuntu a few years ago. – Mike May 17 '15 at 14:52
  • When I plug the cable into a USB 2.0 port and also a USB 2.0 hub, the system does not lock up. So it looks to me the bug might be in a USB driver. A few more details. I have a 3TB Seagate and 4TB Seagate USB drive. The enclosures look the same. The 3TB one does not make the system lock up, and mounts fine. It appears to operate at 3.0 speeds. The 4TB one always makes the system lock up (without even a kernel panic). The USB 3.0 ports (2) are provided through a PCI card. The motherboard only offers 2.0 ports. I did not have to install any drivers to make it work. – Mike May 17 '15 at 15:06
  • I'd like to reiterate my observation that USB on Xubuntu, most likely same as on Ubuntu, and pretty likely on Linux across the board, that USB just remains flaky. Drive continue to sometimes automatically mount, and sometimes not. It's such a frustrating mess. – Mike May 25 '15 at 23:33
  • ... discovered more bugs. Sometimes it gets confused. I mount a drive, but something goes wrong. The mount point at /media/mike/disk becomes faulty. It wants to auto mount, but then "remembers" a previous mount failure, and then immediately unmounts again. It does that all by itself a bunch of times. Mount, unmount, mount, unmount, and then it gives up and remounts at /media/mike/disk1... I feels to me that USB in general on Linux, is at the stage you'd expect around the year 2000. Flaky and unreliable and unpredictable. – Mike Jun 23 '15 at 22:03

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.