5

On my dell laptop (XPS 13 developer) running Fedora 21 I am in a situation similar to this, or this. I can give some more details tough.

Under directory /sys/class/backlight I have:

dell_backlight/brightness
intel_backlight/brightness

Where the first is brought-in, I guess, by dell_laptop module, while the second comes from i915. Trying to adjust screen brightness works with intel_backlight only (by echoing values), while trying to fiddle with other makes no change, with no errors.

The problem is that gnome3 menu settings, and the hotkeys, both try to work around dell_backlight (the hotkeys management should be in dell_wmi module).

Is there a way to make GNOME use the other, by some setting in gconf maybe? Or just to rewire the hotkeys and the slider to some script?

Edit:

My laptop has a:

Intel Corporation Haswell-ULT Integrated Graphics (rev 09) (prog-if 00 [VGA controller])
Subsystem: Dell Device 060a
[...] 
Kernel driver in use: i915

This works (with gnome running or not):

echo 250 > /sys/class/backlight/intel_backlight/brightness

This does not:

echo 250 > /sys/class/backlight/dell_backlight/brightness

I know that gnome-shell is trying to adjust dell_backlight and not intel_backlight, because using the brightness slider in the tray menu, I can read value changes in dell_backlight.

  • What graphics card you have? Can you adjust the brightness when Gnome shell isn't running? – Braiam May 16 '15 at 15:48
  • 2
    @Braian His graphical card is the build in from Intel (i915) and he can adjust the brightness. – switch87 May 16 '15 at 21:49
  • 2
    This is most likely caused by gnome-settings-daemon power plugin. Unfortunately I'm not able to help you as I'm using another distro (archlinux, kernel 4.0.1 & gnome 3.16.1) and everything works fine here (my laptop is Dell XPS L502x). I don't even have that dell_backlight directory, instead I have acpi_video0 alongside intel_backlight. Though you might want to try this. – don_crissti May 16 '15 at 23:39
  • When you press the keys to adjust the brightness, do you get the on-screen brightness display at all? Odds are good that this is basically a bug — in fact, if you have to hack anything here, it is. Check out this debugging block post, and file a bug with the requested info, please. (And thank you. Disclaimer: I work on Fedora.) – mattdm May 16 '15 at 23:49
  • @don_crissti that fixes it; please turn it into an answer and i'll accept it (no idea how i could miss the search result when googling for it!) – guido May 16 '15 at 23:53
1

I would remove dell_backlight/brightness


I would then add:

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash acpi_backlight=intel"

To your grub file then:

update-grub
0

You could probably just shortcut:

xbacklight -dec 10 & xbacklight -inc 10 to whatever keys you want. I do this in Fluxbox like so:

echo "232 :Exec xbacklight -dec 10" >> ~/.fluxbox/keys
echo "233 :Exec xbacklight -inc 10" >> ~/.fluxbox/keys
  • no xbacklight and no fluxbox here. i can change brightness from the terminal; i want to fix gnome-shell backlight operation. – guido May 16 '15 at 22:47
  • Gnome-shell is similar to mate. Just set a keyboard shortcut (XF86MonBrightnessUp for instance) to xbacklight -dec 10 [for dimming by 10%, and xbacklight -inc 10 for incrementing 10%. Doesn't matter what DE you are in. – ryanpcmcquen May 17 '15 at 1:22

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.