I have updated my KVM management script for Ubuntu 14.04 KVM hosts to support debian 8 guests. After a manual installation (preseed script does not work yet), I am stuck with the the following message on bootup:

enter image description here

During the installation, I:

  • Selected only ssh server and base system utilities.
  • Set the grub bootloader to install to the only listed option.
  • Used the guided partitioning mode for everything on one partition.
  • Used the local UK mirror.

Is there some step I need to be careful to make or can Debian 8 not yet be installed as a KVM guest?


After giving up and deciding to just upgrade a debian 7 VM to debian 8 by updating all of the lines in /etc/apt/sources.list to jessie instead of wheezy, I found that I eventually got the same behaviour.

However this instance had a static IP and I found that I could still SSH into the server on that IP, so it looks like this is some sort of graphics issue where the server does manage to boot up, we just can't see the login text. How can I resolve this?


This time, on the debian installation created by upgrading debian 7, I can click advanced from the grub menu and select the option with (sysvinit) which works for now. I am hoping this can lead to an explanation of what is going wrong with the normal version that gets booted?

enter image description here


3 Answers 3


Thanks to the link @Someone posted in the comments to the question, I was able to pull this content which fixed the issue for me:

  1. on the boot screen (below) press the "e" key to edit the configuration. enter image description here

  2. You will be shown a screen like follows. enter image description here

  3. Scroll down using the keyboard down arrow. You want the line that says linux enter image description here

  4. Add the text console=ttyS0 after the word quiet and then press cntrl + x to proceed enter image description here

  5. Now as root, or using sudo, run the command systemctl enable getty@ttyS0 in order to never have to go through all those steps again.

  • If this happens to you on a virtual terminal on a KVM guest with no ssh access (yet), Escape it to your host shell, then you have to be quick on the keys. Type virsh console YOURVM which should fail but then you type virsh reboot YOURVM then immediately up, up, enter to replay the console command then keep tapping up until you see the grub menu and you've prevented the default from loading.
    – Walf
    May 5, 2017 at 14:57
  • @Walf rather than be quick on your keys, you can just use && to queue the commands like: sudo virsh reboot my-vm-id && sudo virsh console my-vm-id May 6, 2017 at 6:35
  • I assumed that the start would be asynchronous and that the console may not exist immediately. Oops.
    – Walf
    May 6, 2017 at 12:09
  • To persist the console=ttyS0 setting, you can edit file /etc/default/grub, line GRUB_CMDLINE_LINUX. help.ubuntu.com/community/Grub2/Setup#Specific_Entries Oct 18, 2017 at 9:23

I've encountered the same problem! The result showed that the virtual machine might be out of cpu or memory resource and I solved it by adding arguments "-smp 4 -m 2048"

Initially, I was running qemu with command

qemu-system-x86_64 -hda debian.img -enable-kvm -nographic

But the new kernel was stuck at "Loading initial ramdisk"

Later, I tried with

qemu-system-x86_64 -hda debian.img -enable-kvm -nographic -m 512 -smp 4

then, there is a kernel panic, saying "Kernel panic - not syncing: Out of memory and no killable processes..."

Finally, it's the solution

qemu-system-x86_64 -hda debian.img -enable-kvm -nographic -m 2048 -smp 4
  • I just tried this and it didnt work for me. Jun 4, 2015 at 14:36

Thanks, the selected answer solved my problem too on Debian8 on a newly created VM. Adding console=ttyS0 got me the console.

But an important additional information: Like the post author I also created the VM with only base-system and ssh-server. Like many in this situation I was not really interested in having a console but mainly SSH.

So it's important to know that even if the VM might seem stuck, it is running correctly and you can ssh into it. You could also start the VM without the --console option.

If you used the default network setting (NAT and DHCP) you can get the IP assigned to your VM issuing:

# virsh net-dhcp-leases default

Or as user:

$ virsh --connect qemu:///system net-dhcp-leases default

(use the network name your VM are on if it is something else than default)

Knowing the IP you can ssh into your VM.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .