3

I'm trying to play an audio CD in Debian but each time I insert the CD, while there appears an icon with the CD in the screen, when I try opening it I get the message:

Failed to mount "Audio CD". Location is not mountable.

I've been searching since yesterday but as I see there is a general problem with audio CDs because the system cannot mount them (they are iso data?) So, is there a way to fix this problem?

Note: I have found suggestions of using cdparanoia or soundjuicer. Should these programs solve the problem(if truly there is one)?

Note2:

I have tried these:

   root@debian:/home/kwstas# mkdir /mnt/cd && mount /dev/cdrom /mnt/cd
   mount: /dev/sr0 is write-protected, mounting read-only
   mount: wrong fs type, bad option, bad superblock on /dev/sr0,
   missing codepage or helper program, or other error

   In some cases useful info is found in syslog - try
   dmesg | tail or so.



   root@debian:/home/kwstas# mkdir /mnt/cd && sudo mount /dev/cdrom /mnt/cd
   mkdir: cannot create directory ‘/mnt/cd’: File exists


   root@debian:/home/kwstas# mount /dev/cdrom /mnt/cd
   mount: /dev/sr0 is write-protected, mounting read-only
   mount: wrong fs type, bad option, bad superblock on /dev/sr0,
   missing codepage or helper program, or other error

   In some cases useful info is found in syslog - try
   dmesg | tail or so.`
  • 1
    Why would you want to 'mount' audio cd? Usually you just play it with mplayer -cache 5000 cdda://1 where 1 is your track no. – UVV May 18 '15 at 9:17
2

You could try to use these commands in the terminal:

mkdir /mnt/cd && mount /dev/cdrom /mnt/cd

Else try this in the terminal:

sudo mkdir /mnt/cd && sudo mount /dev/cdrom /mnt/cd

Or, if mkdir works:

mkdir /mnt/cd && sudo mount /dev/cdrom /mnt/cd 

Or, if the directory has already been created:

sudo mount /dev/cdrom /mnt/cd

Edit: I've googled and found this link.

It's about mounting an audio CD. It reads you can't mount them because of no filesystem. You need another program indeed.

  • Hi, thanks for the reply. I have tried your suggestions. I will make an edit to my post to show you the results. It didn't work. – Constantine Black May 18 '15 at 8:56
  • Try dmesg | tail or so – TheRealProcyon May 18 '15 at 9:10
  • I got: root@debian:/home/kwstas# dmesg | tail [ 79.736723] sr 5:0:0:0: [sr0] [ 79.736728] Result: hostbyte=DID_OK driverbyte=DRIVER_SENSE [ 79.736731] sr 5:0:0:0: [sr0] [ 79.736733] Sense Key : Illegal Request [current] [ 79.736736] sr 5:0:0:0: [sr0] [ 79.736740] Add. Sense: Illegal mode for this track [ 79.736743] sr 5:0:0:0: [sr0] CDB: [ 79.736744] Read(10): 28 00 00 00 00 00 00 00 01 00 [ 79.736751] end_request: I/O error, dev sr0, sector 0 [ 79.736769] EXT4-fs (sr0): unable to read superblock – Constantine Black May 18 '15 at 9:20
  • It looks like the cd is broken – TheRealProcyon May 18 '15 at 9:21
  • What do you mean? – Constantine Black May 18 '15 at 9:23
3

You don't mount Audio CDs. You can read about it here Mount CD ROM in Linux at 4. Mounting Audio CD chapter.

In order to listen to a music CD all what needs to be done is to insert music CD ( Compact Dics ) into CD-ROM/DVD-ROM drive and fire up you favorite music CD player.

In order to listen to Audio CD you can refer to this article Mplayer: Play Audio CD. What you need to do is simply use a command below:

mplayer -cdrom-device /dev/cdrom -cache 5000 cdda://1

where 1 is your track number, and -cache 5000 option indicates that mplayer should cache 5 seconds of audio to avoid delays when CD stops (when you use Pause).

  • Thanks for the reply here. I now know- you are correct. I will install a music player. – Constantine Black May 18 '15 at 9:53
1

If you want to see an audio CD in your file system, assuming it is functioning and visible in your file explorer, look for it to have been auto-mounted at /run/user/$(id -u)/gvfs/cdd*.

In other words, you can play a CD from the command line with:

find /run/user/1000/gvfs/cdd* -iname "*.wav" -print0 |xargs -0 -n1 aplay

Warning: This might suffer from underruns due to a lack of buffering.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.