I'm running KDE on Fedora Workstation 21.

When I wake up my machine after suspending it, it always prompts for my password.

If there any way to disable this? I've looked through the settings but can't see how this is done.

up vote 7 down vote accepted

Power management -> advanced settings -> Lock screen on resume.

EDIT: In new Plasma vesrions, it's in

System settings -> Desktop Behaviour -> Screen locking.

Quick tip: In the systemsettings screen, there is an useful dialong in which you can search for "lock", it'll highlight the relevant icons.

  • Doesn't work for me: I found Power Management as a tab within "Monitor & Display" but it doesn't have advanced settings. – user829755 May 10 '16 at 19:15
  • @user829755 Plasma has changed wuite a lot in the last year. I edited the answer. – AF7 May 11 '16 at 8:32
  • thanks for the update. I still can't find it here, but that's probably due to my Trinity Desktop Environment. TDE has System Settings > Desktop > Screen Saver > Require password to stop but that's not related to suspend/resume. – user829755 May 13 '16 at 23:09
  • 1
    @user829755 Trinity is a fork of KDE3. Two versions old. It's just a completely different thing, it is not KDE. Please do not confuse possible readers by mixing the two. – AF7 May 14 '16 at 17:36

For me following works:

gsettings set org.gnome.desktop.lockdown disable-lock-screen true

found at https://forums.linuxmint.com/viewtopic.php?f=90&t=82103?f=90&t=82103

I'm doing this at home for convenience. When I take the notebook out of the house I set it back to false so that my stuff is a little more secure when the notebook is stolen.

TDEpowersave does it on this laptop. Locate its icon on the panel, it looks like a power plug with a battery bar beside it. Right-click, select settings, and look for something like "screen lock" (sorry, can't guess the exact English wording, an i18n version here.) Disable it. Did the trick for me.

  • I'd say this question is to with KDE4 / plasma, not a feature of the Trinity fork (TDE), which google suggests is only available for Fedora as a third-party repo. – sourcejedi Nov 22 '17 at 16:40
  • You are very welcome to document what solved your own problem, as a separate question - the site allows and deliberately supports answering your own question - there is a feature that lets you post both at once. – sourcejedi Nov 22 '17 at 16:42
  • When you have more reputation, you would be able to add a comment in direct response to the one by user829755, to point to the more appropriate question. – sourcejedi Nov 22 '17 at 16:45

Your Answer

 

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.