1

I installed and removed some packages and changed some settings on my Debian server. After reboot I can't run x11vnc to remote it using VNC. Now when I run startx, the result is:

 no screens found

X -configure:

 Number of created screens does not match number of detected devices.
  Configuration failed.

x11vnc -auth guess gives me:

 failed for display='unset'
 since we are root, retrying with FD_XDM=1
 failed for display='unset'

I don't know what my server configurations is but my fresh installation of Debian worked nice. Now I installed KDM, KDE, Gnome, Xorg, etc. to get the graphical screen but I don't know what some of them are.

How can I fix my system without reinstalling?

0

I removed every package related to Desktop and Window environment with aptitude and installed x-window-system, xfce4, gdm3, vnc4server.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.