2

I am running on 64 bit OpenSuSe 13.2 with Gnome 3 desktop environment and unsuccessfully trying to set up Samba Server. I have another computer running windows 8.1 from which I am pinging the ip address of my Linux machine. My firewall is disabled. What other factors could be blocking my linux machine?

I can successfully ping on my windows 8.1 from my linux machine though.

Note I have two routers (tp-link ASDL) and (netis). Sometimes I can ping and access local webserver of linux (apache) from windows 8.1 I am guessing this is due to slow connection problem.

Here is output of ifconfig of linux

nuke1:/home/santoshlinkha # ifconfig
enp3s0    Link encap:Ethernet  HWaddr F4:6D:04:56:9B:2B  
          UP BROADCAST MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:0 (0.0 b)  TX bytes:0 (0.0 b)

lo        Link encap:Local Loopback  
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:65536  Metric:1
          RX packets:5808 errors:0 dropped:0 overruns:0 frame:0
          TX packets:5808 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0 
          RX bytes:7368235 (7.0 Mb)  TX bytes:7368235 (7.0 Mb)

wlp2s0    Link encap:Ethernet  HWaddr BC:77:37:AC:63:7C  
          inet6 addr: fe80::be77:37ff:feac:637c/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:93117 errors:0 dropped:0 overruns:0 frame:0
          TX packets:98142 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:58302013 (55.6 Mb)  TX bytes:27770084 (26.4 Mb)

Here is output of my ipconfig in windows 8.1

Windows IP Configuration


Wireless LAN adapter Local Area Connection* 4:

   Media State . . . . . . . . . . . : Media disconnected
   Connection-specific DNS Suffix  . : 

Wireless LAN adapter Local Area Connection* 3:

   Media State . . . . . . . . . . . : Media disconnected
   Connection-specific DNS Suffix  . : 

Wireless LAN adapter Wi-Fi:

   Connection-specific DNS Suffix  . : 
   Link-local IPv6 Address . . . . . : fe80::edc2:243b:ad78:3b1d%8
   IPv4 Address. . . . . . . . . . . : 192.168.1.108
   Subnet Mask . . . . . . . . . . . : 255.255.255.0
   Default Gateway . . . . . . . . . : 192.168.1.1

Ethernet adapter Bluetooth Network Connection:

   Media State . . . . . . . . . . . : Media disconnected
   Connection-specific DNS Suffix  . : 

Ethernet adapter Ethernet:

   Media State . . . . . . . . . . . : Media disconnected
   Connection-specific DNS Suffix  . : 

Tunnel adapter isatap.{87EDE97A-520D-44AA-B06B-9A89EDC96497}:

   Media State . . . . . . . . . . . : Media disconnected
   Connection-specific DNS Suffix  . : 

Tunnel adapter Teredo Tunneling Pseudo-Interface:

   Connection-specific DNS Suffix  . : 
   IPv6 Address. . . . . . . . . . . : 2001:0:9d38:90d7:2833:cc04:8e38:2b5d
   Link-local IPv6 Address . . . . . : fe80::2833:cc04:8e38:2b5d%11
   Default Gateway . . . . . . . . . : ::

enter image description here

closed as off-topic by Jeff Schaller, Stephen Rauch, G-Man, Anthon, Archemar Sep 27 '17 at 6:45

This question appears to be off-topic. The users who voted to close gave this specific reason:

  • "Questions describing a problem that can't be reproduced and seemingly went away on its own (or went away when a typo was fixed) are off-topic as they are unlikely to help future readers." – Jeff Schaller, Stephen Rauch, G-Man, Anthon, Archemar
If this question can be reworded to fit the rules in the help center, please edit the question.

  • What does wireshark say, when sending ICMP-Echo-Requests? – Thomas Junk May 14 '15 at 11:35
  • @ThomasJunk I haven't installed wire shark. I'll install it and let you know ... also do you mean it from win -> linux or linux -> win?? – Santosh Linkha May 14 '15 at 11:36
  • It will be useful to put additional information as :IP address, netmask and default gateway of each equipment. – jcbermu May 14 '15 at 12:01
  • 3
    It seems to me, that your PC does not have a vailid IPv4 and IPv6 address for the local network. I guess your are using the LAN connection so please try to run dhclient enp3s0 which will try to get a IP adress from the DHCP server (your router). Then have a look at ifconfig again. – Benjamin May 14 '15 at 12:23
  • 1
    Seems Like you are using systemd's NetworkManager, try setting it to the legacy ifup method or configure NetworkManager acordingly. Maybe you could also try to configure a static IP. – Benjamin May 14 '15 at 13:26
0

One possible cause is the firewall rejecting ICMP traffic. To test the hypothesis turn off the firewall in yast and try again.

  • I found that my ip-address is 192.168.1.4 on both routers. On tp-link router, I have another router with the ip address 192.168.1.4 in the bridge mode. That was causing the problem. – Santosh Linkha May 14 '15 at 19:21
  • @Trevor: The question says, "My firewall is disabled." – G-Man May 14 '15 at 19:37
  • @G-Man true. I missed it. – Trevor Brown May 14 '15 at 19:39

Not the answer you're looking for? Browse other questions tagged or ask your own question.