So I have a 4k display, and for some reason Ubuntu decides that it's a good idea to give me a huge cursor instead of something normal. I don't have any DPI settings on the 4k monitor, and I don't want any, so why is the cursor so huge? This is how it looks like:

This is on Ubuntu 15.04 with XFCE4 with Nvidia drivers.

It only looks like that when the mouse is over system-dependant things (or something in that nature), such as the desktop, window titles, menu bar (File, Edit, View, ...) and context menus.

In Firefox it seems to work just fine, except in the bookmarks dropdown.

What I've already tried:

  • Running update-alternatives to force the cursor theme. This changes the cursor theme, but it doesn't change the cursor size.
  • Modify the cursor size in dconf-editor. This doesn't do anything.
  • Put Xcursor.size: 24 in ~/.Xdefaults. This also doesn't appear to do anything.

xrdb -query returns the following:

*customization: -color
Xft.dpi:    96
Xft.hintstyle:  hintnone
Xft.rgba:   none
Xcursor.theme:  DMZ-Black
Xcursor.size:   24
Xcursor.theme_core: 1
  • Did you try changing the theme and/or the pointer setting in the theme?
    – shivams
    May 13, 2015 at 21:27
  • Yes, the pointer size as shown by dconf-editor is 24, which is the default. I can change the cursor theme to something else, but the size remains the same.
    – Codecat
    May 13, 2015 at 21:29
  • I've also tried setting the pointer size to 16, there is no change.
    – Codecat
    May 18, 2015 at 8:41

5 Answers 5


I ended up solving it myself (kind of). It's not the ultimate way, but it's a workaround that I can live with myself.

Essentially, I took the original sources of the DMZ-Cursors package and created a fork of DMZ-Black, then I removed the 32x32 and 42x42 images, and am now using that as my cursor set.

For convenience sake, I've put up my version of DMZ-Black on Github: https://github.com/codecat/dmzblack-96dpi

If you wish to do the same with DMZ-White, simply download the sources here, copy DMZ-White, and remove all lines mentioning 32x32 and 42x42 in the *.in files. You can also remove the folders for those images if you want. Then simply run make.sh and copy the generated cursor files (in ../xcursors) to your cursors folder. (You can take my install script and change_cursor.sh as an example.)

  • I just joined this site so I could login and up-vote you for this. amazing, ty. Apr 15, 2022 at 14:09

cursor settings

I was able to fix this in Kubuntu 19.10 by changing from "resolution dependent" to a fixed size in the Cursor settings.


I came up against this same issue, but didn't want to switch to one of the DMZ cursor themes, so I figured out how to apply @Angelo Geels' method to the Oxygen cursor themes:

# Ensure that dependencies are installed
sudo apt-get install cmake inkscape

# Download the cursor source
wget http://archive.ubuntu.com/ubuntu/pool/universe/o/oxygencursors/oxygencursors_0.0.2012-06-kde4.8.orig.tar.gz

# Unpack
tar -xvzf oxygencursors_0.0.2012-06-kde4.8.orig.tar.gz
cd oxygencursors-0.0.2012-06-kde4.8.orig

# The critical modification step
sed -i "s/90 180 270/90/" theme-*/CMakeLists.txt

# Prepare the build directory
mkdir build
cd build

# Build the cursors
cmake ..
make # This will take a long time, so use -j<n> or specify a single cursor to build (make theme-<color>)

When this process is done, the modified themes will be in build/packages to install however you wish (with lxappearance, for example).


I had the same problem and I noticed that if I have the login set to auto, then cursor is big and regardless of all my attempts (I've tried all suggestions posted here) it will not change to regular size. If I have auto login switched off so that I need to enter my password at login, the cursor is of correct size.


Update your cursor theme and cursor size first of all

First in a terminal type:

sudo update-alternatives --config x-cursor-theme

Choose the number of the theme you want - e.g.

0 for DMZ-White

Reboot your system. Using dconf-editor (install using sudo apt-get install dconf-tools) navigate to


enter image description here change the cursor size to

24 and cursor theme to DMZ-White
  • OP has perhaps already tried this, as mentioned in the comments.
    – shivams
    May 18, 2015 at 13:21
  • I checked it round a bit, and many have reported getting inconsistent results. It may be a bug in the system. May 18, 2015 at 15:38
  • Yes, this doesn't work for me unfortunately. It changes the theme of the cursor after the reboot, but it doesn't change the size.
    – Codecat
    May 18, 2015 at 16:31
  • 1
    After further testing found out that the sudo update-alternatives --config x-cursor-theme command to choose one among cursors with manual mode was sufficient. Reboot your system after that. Hope this works... May 18, 2015 at 18:34
  • That changes the cursor theme, yes, but not the cursor size, which remains the same.
    – Codecat
    May 19, 2015 at 8:35

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .