I use iwconfig to show me some information about my current internet connection like this

$ iwconfig
wlp2s0    IEEE 802.11abg  ESSID:"eduroam"  
          Mode:Managed  Frequency:2.462 GHz  Access Point: 06:0B:6B:2E:A7:80   
          Bit Rate=6 Mb/s   Tx-Power=22 dBm   
          Retry short limit:7   RTS thr:off   Fragment thr:off
          Power Management:off
          Link Quality=42/70  Signal level=-68 dBm  
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:0  Invalid misc:19522   Missed beacon:0

lo        no wireless extensions.

In the past these information were updated each time I ran the command. Lately, the information remain the same from the beginning of the connection. The same applies to what I get via cat /proc/net/wireless. What may be the reason for this and how can I fix it?

  • I have the same problem. My kernel is: Linux brilliant-laptop 4.0.4-2-ARCH #1 SMP PREEMPT Fri May 22 03:05:23 UTC 2015 x86_64 GNU/Linux Jun 15, 2015 at 17:09
  • And my card is RTL8187L. Jun 15, 2015 at 17:15

1 Answer 1


The answer was given by an update of the arch linux kernel to 4.1.2. Now it works again, thus it must have been something to do with the kernel version.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .