1

I am trying to mount a folder in Windows (shared by Everyone) to a centOS server using cifs. In /etc/fstab, I got:

//192.168.x.x/DOUGSLAPTOP/hatest /mnt/fsr01 cifs guest 0 0

I have also tried doing this:

//192.168.x.x/DOUGSLAPTOP/hatest            /mnt/fsr01      cifs    users,rw,user=Ryan,pass=Mon30 0 0        

When I make this change, I get this for a response:

mount error(110): Connection timed out
Refer to the mount.cifs(8) manual page (e.g. man mount.cifs)

I don't think this is has to do with my firewall because I turned it off temporarily. Does anyone else have any other suggestions?

1

Best way for non-user-name password is :

sec=none

Above configuration is mount option of mount.cifs

  • How do i apply this to mounting, I never used mount.cifs before.. – ryekayo May 13 '15 at 12:40
  • You have to use mount -t cifs -o sec=none //192.168.x.x/DOUGSLAPTOP/hatest /mnt/fsr01 – PersianGulf May 13 '15 at 13:15
  • That didn't work. I updated my question – ryekayo May 13 '15 at 13:35
  • I think you add some optin to your mount please read man mount.cifs – PersianGulf May 13 '15 at 14:13
  • I don't think this has to do with the problem, bus the mount.cifs manpage in Centos 7 states: """... While some versions of the cifs kernel module accept "user=" as an abbreviation for this option, its use can confuse the standard mount program into thinking that this is a non-superuser mount. It is therefore recommended to use the full "username=" option name. ...""" – spuk May 26 '15 at 15:56
1

Providing option guest should make it not ask for a password, but it obviously won't work if a password is needed.

If a password is needed you can pass it as an option (username=x,password=y), or (better) pass a file with the credentials (username, domain, password) as an option (credentials=/etc/cifs_mountpoint.cred).

man mount.cifs for more details. You should also add _netdev as an option, and maybe nofail too.

  • the reason why i added guest was because I was taking a wild guess...I did this before successfully, i wish i remembered how i set this.. – ryekayo May 12 '15 at 21:56

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.