1

I have Debian GNU/Linux 8 Jessie (DE GNOME Shell 3.14.2) installed on my machine. After having set Alt + PageUp and Alt + PageDown shortcuts for multimedia sound volume Up\Down respectively, I found my default Up\Down-volume shortcuts Fn + F2 and Fn + F3 not working. Worth to mention that sound On\Off Fn + F1 works well.

I'm going to add "duplicate" shortcuts Fn + F2/F3 which will Up-and-Down volume as Alt + PageUp/PageDown now do. But I couldn't find the Command for any these default shortcuts (all i can do is to change shortcut combination; can't change even its Name field!).

And here is the question: where can I find the commands of these default keyboard shortcuts?

(I'll attach a few screenshots, maybe they will clarify this issue) This is what I call the "default" shortcut, whose Command I want to find: This is what I call the "default" shortcut, whose <code>Command</code> I want to find.

And here are Name and Command fields I'm talking about. This is Name and Command fields I'm talking about.


SOLUTION:

Finally, with a hint of don_crissti user, I created two scripts and passed as Command their location in this way:

Location, also a Command:

/usr/MY_SCRIPTS/volumeUp.sh

Script itself:

amixer -q sset Master 3%+

Now, it works! The notification pop-up icon that shows the level appears only with default Fn + F2(F3) but it doesn't matter (maybe, I'll try to solve this later).

However, the there is still no answer on question where to find the commands like: sound volume up/down, turn ON/OFF the display, enable Numpad, display brightness More/Less, turn On/Off wireless etc., you know, all these actions which are marked on laptops' keyboard.

So I'll keep this question open until it becomes clear.

(UPDATE: will edit Q and post A soon.)

  • Shortcuts are controlled by the desktop environment, not by the distribution. What desktop environment are you using? – Gilles May 12 '15 at 23:38
  • @don_crissti, thanks for attention! Now, when I have set Volume Up\Down to Fn+F2(F3), and according to a link you gave, amixer -q sset Master 3%+ to Alt+PageUp(Down), the Fn-combinations work well now, but pressing Alt+PadeUp(Down) causes setting Volume level to 0. Here I can guess it sees another combiation, but there's something wrong with something... I, I don't know. I remember how on Windows I had default (Fn+F2(F3)) working well, and set up additional Alt+PageUp(Down) in AIMP3 audio player. But there is no such key-binding option in Rhythmbox, that's a pity! – yulian May 12 '15 at 23:39
  • @Gilles, GNOME Shell 3.14.2 – yulian May 12 '15 at 23:41
  • @don_crissti, standard (that's Fn-combinations) are because there is marked keys on the keyboard, so other people will be able to change the volume level. Alt-combinations are for specially me ;) It's on my laptop (Dell Latitude 3340), as all keys are in one area, I use them to control multimedia: Alt+PageUp(Down) for volume, Alt+Left(Right) for prev or next track, Alt+Down for play\pause, Alt+Up for stop. And it would be better to make Alt-s for +/- 3%, while Fn-s will change it by 6%. – yulian May 13 '15 at 0:03
  • 1
    Works fine here both with pactl and amixer though I placed the commands in two separate scripts and the two shortcuts run the scripts. – don_crissti May 13 '15 at 0:39

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.