3

On a ubuntu server, I try to do "sudo modprob" and I have this error :

$ sudo depmod
[sudo] password for deployer:
depmod: ERROR: could not open directory /lib/modules/3.8.0-38-generic: No such file or directory
depmod: FATAL: could not search modules: No such file or directory

I tried to reinstall the kernel but I have this :

$ sudo apt-get install --reinstall linux-headers-3.8.0-38 linux-headers-3.8.0-38-generic linux-image-3.8.0-38-generic
Reading package lists... Done
Building dependency tree
Reading state information... Done
E: Unable to locate package linux-headers-3.8.0-38
E: Couldn't find any package by regex 'linux-headers-3.8.0-38'
E: Unable to locate package linux-headers-3.8.0-38-generic
E: Couldn't find any package by regex 'linux-headers-3.8.0-38-generic'
E: Unable to locate package linux-image-3.8.0-38-generic
E: Couldn't find any package by regex 'linux-image-3.8.0-38-generic'

I tried to install a latest version like this :

sudo apt-get install linux-headers-3.13.0-24 linux-headers-3.13.0-24-generic linux-image-3.13.0-24-generic

But I always have this result :

$ uname -r
3.8.0-38-generic

I don't know why it does not change.

Do you have a solution ?

  • Have you (after successful installation) rebooted the Linux? (Though, if you got installation errors and your installation failed you should have a look into that first.) – Janis May 12 '15 at 9:49
  • Yes I did. I finally found the solution. – Dougui May 12 '15 at 9:57
0

I found the solution. I did not think it was important but I am a Digital Ocean's VPS. I followed this solution. I had to change the kernel version in the control panel and reboot through the control panel.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.