5

I'm using Sublime Text 3 on Linx Mint MATE edition, installed on a laptop with a 4K 15.6 inch display. The high dpi means that most UI's have to be scaled. I have gotten most of the programs I use daily to scale nicely, except for Sublime Text (3).

It is possible to enable "high dpi" mode in Sublime Text 3 by setting the gsettings/dconf key org.gnome.desktop.interface text-scaling-factor to something larger than 1 (2 works great for me), for example with the command:

gsettings set org.gnome.desktop.interface text-scaling-factor 2.0

The problem is that, for this to have an effect, I have to have gnome-settings-daemon running. The MATE desktop environment (which is a fork of the no-unmaintained GNOME 2) uses it's own settings daemon (mate-settings-daemon), and it is not possible to run both this and gnome-settings-daemon at the same time. When I try starting gnome-settings-daemon with mate-settings-daemon already running, I get the following error (among others):

** (gnome-settings-daemon:4051): WARNING **: You can only run one xsettings manager at a time; exiting

I would prefer to keep using the MATE desktop.

Does anyone know of a way around this? Or a different way of enabling high dpi support in Sublime Text 3, without having gnome-settings-daemon running?

1
  • Did you try putting stuff in ~/.config/gtk-3.0/settings.ini? I have [Settings] gtk-cursor-blink = false, which works when gsd-xsettings is not running. Sep 28, 2018 at 21:52

1 Answer 1

2

Put this in your Preferences.sublime-settings:

"dpi_scale": 2.0

1
  • I just edited this reply, thinking it was my reply. Sorry for the judgemental comment in my edit note! (I wish there was a PM function in cases like these).
    – Filip S.
    Nov 19, 2015 at 9:11

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .