5

Basically the packages kbd, console-setup, console-setup-linux, and keyboard-configuration all depend on each other. So I cannot remove, configure, or purge them. When attempting to run:

dpkg --configure <package name>

it returns the error:

dpkg: dependency problems prevent configuration of

It goes on to list the specific dependencies. Upon trying to configure those, it eventually ends up back at the original package.

Am I missing something?


Edit: It appears I can configure keyboard-configuration, but it gives me this error:

user@ip:~$ sudo dpkg --configure keyboard-configuration
Setting up keyboard-configuration (1.108ubuntu5) ...
/var/lib/dpkg/info/keyboard-configuration.postinst: 1: /var/lib/dpkg/info/keyboard-configuration.postinst: udpkg: not found
/usr/bin/ckbcomp: Can not find file "symbols/en" in any known directory
dpkg: error processing package keyboard-configuration (--configure):
 subprocess installed post-installation script returned error exit status 1
Errors were encountered while processing:
 keyboard-configuration
2
  • It's impossible to know without seeing the entire output. Commented May 9, 2015 at 20:00
  • It seems to be an issue with the keyboard-configuration package. The output posed in the second section above is the whole output when trying to configure it. Do you still need to see more?
    – mattrick
    Commented May 9, 2015 at 20:13

2 Answers 2

6

I had exactly the same problem after upgrading a server from 14.10 to 15.04 yesterday. I solved it with these commands:

sudo apt-get remove keyboard-configuration
sudo apt-get install keyboard-configuration
sudo apt-get update && sudo apt-get upgrade
2
  • Worked great, thank you (I probably should have tried this from the beginning)!
    – mattrick
    Commented May 13, 2015 at 6:40
  • 1
    In my case, it has uninstalled some xorg packages...not working >*
    – aloplop85
    Commented Aug 25, 2016 at 10:55
4

I had this problem too. I found two approaches to fix this.

Try first:

Open the file /etc/default/keyboard with your favorite editor and change the value of XKBLAYOUT to "us".

If this did not help try this:

sudo -i
cd /usr/share/X11/xkb/symbols
ln -s us en

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .