0

While my android smartphone has around a dozen different wifi networks available, I can’t get this card get more than two at best.

lshw -c network reports:

  *-network
       description: Wireless interface
       product: AR922X Wireless Network Adapter
       vendor: Qualcomm Atheros
       physical id: 0
       bus info: pci@0000:0f:00.0
       logical name: wlan0
       version: 01
       serial: da:45:28:45:56:30
       width: 32 bits
       clock: 66MHz
       capabilities: pm bus_master cap_list ethernet physical wireless
       configuration: broadcast=yes driver=ath9k driverversion=3.16.6 firmware=N/A latency=168 link=no multicast=yes wireless=IEEE 802.11bgn
       resources: irq:18 memory:fa300000-fa30ffff

rfkill doesn’t report that the device is blocked in any way

# rfkill list
0: phy0: Wireless LAN
        Soft blocked: no
        Hard blocked: no

It shows up in iwconfig

# iwconfig wlan0
wlan0     IEEE 802.11bgn  ESSID:off/any  
          Mode:Managed  Access Point: Not-Associated   Tx-Power=16 dBm   
          Retry short limit:7   RTS thr:off   Fragment thr:off
          Encryption key:off
          Power Management:off

And ifconfig can get the interface up

# ifconfig wlan0 up
# ifconfig wlan0
wlan0: flags=4099<UP,BROADCAST,MULTICAST>  mtu 1500
        ether da:45:28:45:56:30  txqueuelen 1000  (Ethernet)
        RX packets 0  bytes 0 (0.0 B)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 0  bytes 0 (0.0 B)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

iw dev wlan0 scan however, reports too few results, so the AP I am trying to connect to, is unavailable despite the fact, that even my smartphone that currently uses it, says that the signal is ‘good’. It’s a public AP, so I don’t think that there is some kind of MAC filter or a limited count of peers. The AP isn’t hidden or anything like that, so how do I widen the range of available networks? The card is discrete and has three separate antennas, so I don’t understand how this card can be weaker than the one in my smartphone.


upd:

I don’t know why, but today the card has found the AP, though its signal was only -60 dBm while the one’s that’s always seen was -58. I didn’t do anything, not even shutdown or sent it to hibernation actually. Maybe that’s the weather. The card, however, doesn’t show more than two APs in scan results.

CRDA region is 00, which stands for global. The output of iw dev wlan0 scan from today if somebody interested, is here http://sprunge.us/QWPY

  • Is there any common feature of the networks not shown? Like frequency or type (a/b/g/n)? I am not familiar with Atheros, but maybe you driver does not support all network types. Which one do you have installed and have you tried a proprietary one? – xwst May 10 '15 at 9:11
  • @Stephan I use ath9k driver from the kernel. One network it sees has a signal of -60 dBm and is on the 1 channel, the other has -81 dBm and is on the 8 channel. And the one I want to connect to has a signal of -56 dBm and is on the twelfth channel. Sadly, wi-fi analyzer I have on my android can’t show me whether an AP supports a/b/g/n, but the atheros card I use does, and the driver is known to support it. – tijagi May 10 '15 at 11:34
2

What CRDA region is your box configured for? (CRDA is an acronym for Central Regulatory Domain Agent, see the kernel wiki for more information )
Channel 12 and 13 e.g. are only available outside North America due to regulatory issues, not all channels are permitted for wireless use everywhere. Channel 14 for example is only available in Japan. Check this table for a quick overview. So if your box is currently configured only for channel 1 to 11 you obviously cannot see that network on channel 12.

Please refer to e.g. https://wiki.archlinux.org/index.php/Wireless_network_configuration#Respecting_the_regulatory_domain on how to query and change the CRDA region in a distro-agnostic way, as you didn't mention what distro you're using.

For similar issues, check http://ubuntuforums.org/showthread.php?t=2233283 or https://askubuntu.com/questions/434376/ath9k-driver-suddenly-doesnt-see-channel-13-anymore

If that does not help, you might want to play around with the ath9k module options, try to enable/disable bluetooth coexistence or try to disable hardware encryption via using nohwcrypt=1 option

If that does not help, you may need to read further on this topic about beacon hints

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.