nautilus devices are provided by /usr/lib/gvfs/gvfs-udisks2-volume-monitor, I've already restarted it but one device is still missing. I also tried strace on it, but it only outputs info about mounted devices.

Also, the detection provided by gvfs-mount -l comes from that monitor, but where it gathers information from? If I could determine what is missing/wrong on that detection, may be I could fix it.

I have another very similar device, both are lvm, I checked both with lvdisplay -v -m and there is nothing special about the one that is missing on nautilus.

Despite I can successfully mount it with kvpm, nautilus still ignores it.

Update: The device is missing at tree /dev/disk/ that seems to be populated by udev. So the problem may be fixed by some udev command I think.

Obs.: The missing device had some inode errors but I already fixed them with fsck -vf /dev/dm-6. From this answer, udevadm trigger and vgscan --mknodes also helped on making the device link available again at /dev/<vg>/ (I guess because I had to hard-reset, it went missing there). I fixed it as I believe the monitor may try to read there too. Anyway nothing changed in nautilus even after re-trying actions I detailed previously.

  • a reboot fixed the problem that seems with udev... – Aquarius Power May 9 '15 at 0:51
  • I wonder if this question is still useful to someone or I should just delete it? – Aquarius Power May 9 '15 at 0:53

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.