3

I use UBuntu 14.04 LTS. I have purged all nvidia proprietary drivers and currently my system use Nouveau driver. Here is an output from glxinfo | grep OpenGL :

when using nvidia propietary drivers

OpenGL vendor string: NVIDIA Corporation
OpenGL renderer string: GeForce GTX 970/PCIe/SSE2
OpenGL core profile version string: 4.3.0 NVIDIA 346.59
OpenGL core profile shading language version string: 4.30 NVIDIA via Cg compiler
OpenGL core profile context flags: (none)
OpenGL core profile profile mask: core profile
OpenGL core profile extensions:
OpenGL version string: 4.5.0 NVIDIA 346.59
OpenGL shading language version string: 4.50 NVIDIA
OpenGL context flags: (none)
OpenGL profile mask: (none)
OpenGL extensions:

when using nouveau driver

OpenGL vendor string: VMware, Inc.
OpenGL renderer string: Gallium 0.4 on llvmpipe (LLVM 3.6, 256 bits)
OpenGL version string: 3.0 Mesa 10.6.0-devel
OpenGL shading language version string: 1.30
OpenGL context flags: (none)
OpenGL extensions:

When I run a gpu benchmark triangle test I get following results:

  • nvidia driver: 304455 points, 5073fps

  • nouveau driver: 8466 points, 142 fps

There is a massive drop in performance. Can I change something in nouveau settings to get better results ?

Edit1

glxinfo |egrep -w 'rendering|renderer' :

  • direct rendering: Yes
  • OpenGL renderer string: Gallium 0.4 on llvmpipe (LLVM 3.6, 256 bits)

I don't use the system in Virtual Machine.

1

Did you check if 3d is enabled?

glxinfo |egrep  -w 'rendering|renderer'

If you read something about "raster" or "no",then is not enabled. Even if enabled the opensource driver are good,but there is a lot of work to do to reach at least for old cards the same performance of the nvidia proprietary driver.

Is not clear this

"OpenGL vendor string: VMware, Inc." Using this in a vm?

  • Please see Edit1 – Irbis May 9 '15 at 10:59
1

You'll have to look into your /var/log/Xorg.*.log file (where * means the first number in your $DISPLAY environment variable) to find out why 3D acceleration hasn't been enabled. Gallium 0.4 on llvmpipe is a software renderer, so this indicates that nouveau is not really in use. You can also try the following command to check for warnings about misconfiguration of libGL:

LIBGL_DEBUG=verbose glxinfo > /dev/null

This will redirect all the normal output of glxinfo to /dev/null (the "hole" device) while retaining all the warnings on the console.

0

I've encountered same issue, but under different circumstances. Only available renderer was llvm.

After lot of googling I realised, because of different bug, I put nomodeset into grub (/etc/default/grub) in the line GRUB_CMDLINE_LINUX_DEFAULT

In my setup the machine works without this parameter just fine.

Check, if there is parameter nomodeset in grub and remove it. Try if it helps.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.