0

I'm trying to recompile my xMonad configuration. I know I have to install the ghc packages xmonad and xmonad-contrib. To do this I installed a lot a debian packages including :

  • ghc
  • cabal-install
  • libghc-xmonad-dev
  • libghc-xmonad-contrib-dev

When I do cabal-install xmonad everthing works fine. But when doing cabal install xmonad-contrib I get the following error

XMonad/Util/Invisible.hs:31:59: Not in scope: type constructor or class ‘Applicative’

I found a discussion about this problem on an archlinux forum but nothing worked for me (url)

I'm running debian 8.0. Uname is : Linux guillaume-X99A 3.16.0-4-amd64 #1 SMP Debian 3.16.7-ckt9-3 (2015-04-23) x86_64 GNU/Linux

I'm running Xmonad now (with the default config because I am unable to compile it)

If you have any idea how to make this package compile (or a way to recompile my config without this package) any help would be greatly appreciated.

Best regards

  • 1
    If you installed xmonad and contrib with apt, why do you want to reinstall it with cabal ? You should probably not mix and match packages from different sources, they could have different versions. This is what the thread you linked says. – Leiaz May 8 '15 at 13:03
0

The problem was I ghc packages installed were installed in /usr/lib/ghc/package.conf.d but not in /home/guillaume/.ghc/x86_64-linux-7.8.4/package.conf.d. I just copied them and everything was working.

Thank you

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.