0

I have a crossover cable. I want to move files and folders between my two Ubuntu's. I have partially set this up. They can ping each other. But when I use putty the connection gets refused with no other detail given. How can I allow the connection to take place? UPDATE: the two ip's are 10.0.0.1 and 10.0.0.2 both computers have putty. i am using one computer to connect to the other. 1 to transfer files to 2. i don't have a firewall that I'm aware of. i would like to transfer using ssh I guess but I'm open to suggestions.

UPDATE:

sudo netstat -nap | grep ssh
unix  2      [ ACC ]     STREAM     LISTENING     13150    1619/gnome-keyring- /run/user/1000/keyring-Wr33VU/ssh
  • Is an SSH server running on the target machine? is the SSH port open (not firewalled)? FWIW if you use the native SSH client instead of PuTTY, you can increase the debug level (e.g. ssh -vvv user@hostip), which may help diagnose the issue. – steeldriver May 7 '15 at 22:49
  • ssh -vvv 10.0.0.1 OpenSSH_6.6.1, OpenSSL 1.0.1f 6 Jan 2014 debug1: Reading configuration data /etc/ssh/ssh_config debug1: /etc/ssh/ssh_config line 19: Applying options for * debug2: ssh_connect: needpriv 0 debug1: Connecting to 10.0.0.1 [10.0.0.1] port 22. debug1: connect to address 10.0.0.1 port 22: Connection refused ssh: connect to host 10.0.0.1 port 22: Connection refused – claghorn May 7 '15 at 22:56
  • 1
    @claghorn please do not reply in comments but instead update your Question. The formatting is better, for starters, and it also means that updates don't get lost in a comment thread. – roaima May 7 '15 at 22:58
3

Your netstat command shows that you are not running an ssh server on the target machine. You need to install this from the repository; on Ubuntu it's called openssh-server. Installation will automatically start the daemon.

After it has been installed, you should get output something like this, which shows that the sshd process is LISTEN-ing on port 22:

sudo netstat -nap | grep :22
tcp        0      0 0.0.0.0:22              0.0.0.0:*               LISTEN      861/sshd
tcp6       0      0 :::22                   :::*                    LISTEN      861/sshd

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.