One picture is worth thousand words, so:botched file IO left shade of almost dragged'n'dropped file, how to remove it?

I know log out or restart most likely will do the trick. I want something that doesn't require them.

Tried - no use:

  1. xrefresh
  2. xrandr tricks (revert, change orientation)
  3. Switching the screen on and off (using xrandr)
  4. Changing resolution to force redraw
  5. restarting unity

How to remove the shade? It stays above any window I open, so I can't hide it. If anyone can also explain why copying a file through drag'n'drop ended up this way, would be cool.

Bigger view of a shade, as I see it now, when typing the question: Shade persists

Curious thing, I just tried to drag'n'drop a file over it - I can't. It won't copy/move, unless I move the cursor off the shade, then it performs as expected. So, nomen omen, shade shades the window beneath it and thus prevents from clicking there.

  • Have you tried running xkill and clicking on it? That might kill your desktop, though, so be sure you can restart it. – ThibautRenaux May 7 '15 at 21:40
  • If (as appears likely) you are using a Unity desktop with the compiz compositor, you could try restarting that e.g. compiz --replace &>/dev/null & disown – steeldriver May 7 '15 at 22:08
  • @steeldriver tried restarting entire unity and this did not help. What does disown do? I don't seem to have man for it and man compiz doesn't mention it? – LAFK says Reinstate Monica May 8 '15 at 16:55
  • @ThibautRenaux have not tried it, but seems promising. Will try that. – LAFK says Reinstate Monica May 8 '15 at 16:56

In the end I restarted the system prior to checking xkill. Shame on me, as 'xkill' seemed a more interesting solution. Tried to replicate few times since, but no avail.

UPDATE: Just had a similar problem, but with a cursor. Opened terminal, launched xkill and... cancelled it's run when it asked for which window to kill. Cancelled via Ctrl+c. Cursor returned to normal. :-)

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.