1

I am using Kali, and I tried to upgrade libc6, because it comes with a lower version than I need. After downloading the latest package from the debian repo (https://packages.debian.org/sid/amd64/libc6/download), And installing it using dpkg --auto-deconfigure -i {package} I also installed glib-networking and libglib2.0-0 the same way. Now, when I try to use apt-get It gives the following error:

You might want to run 'apt-get -f install' to correct these:
The following packages have unmet dependencies:
 glib-networking : Depends: libgnutls-deb0-28 (>= 3.3.8) but it is not installable
                   Depends: libproxy1 (>= 0.4.11) but it is not installable
                   Depends: glib-networking-services (>= 2.44.0-2) but 2.32.3-1 is to be installed
                   Depends: glib-networking-common (= 2.44.0-2) but 2.32.3-1 is to be installed
 libglib2.0-0 : Depends: libffi6 (>= 3.0.4) but it is not installable
                Depends: libpcre3 (>= 1:8.35) but 1:8.30-5 is to be installed
                Recommends: xdg-user-dirs but it is not going to be installed
                Breaks: libgnome-desktop-3-2 (< 3.4.2-2) but 3.4.2-1 is to be installed
                Breaks: python-gi (< 3.7.2) but 3.2.2-2 is to be installed
 libglib2.0-bin : Depends: libglib2.0-0 (= 2.33.12+really2.32.4-5) but 2.44.0-2 is to be installed
E: Unmet dependencies. Try 'apt-get -f install' with no packages (or specify a solution).

But, when I try the suggested sudo apt-get -f install It gives me this:

Reading package lists... Done
Building dependency tree       
Reading state information... Done
Correcting dependencies... Done
The following packages were automatically installed and are no longer required:
  apg arduino-core arj audacious-plugins-data avr-libc avrdude binutils-avr dnsmasq-base empathy-common espeak-data extra-xdg-menus fastjar filezilla-common folks-common
  fonts-cantarell fonts-lyx freeglut3 gcc-avr gir1.2-gdesktopenums-3.0 gnome-accessibility-themes gnome-backgrounds gnome-control-center-data gnome-menus
  gnome-packagekit-data gnome-session-common gnome-themes-standard-data hal-info jarwrapper java-wrappers libadns1 libapache2-mod-dnssd libavdevice53 libbinio1ldbl
  libboost-python1.49.0 libbrlapi0.5 libbs2b0 libcairo-script-interpreter2 libcairomm-1.0-1 libcaribou-common libclang-common-dev libcolorblind0 libcpufreq0 libcrypto++9
  libcue1 libdotconf1.0 libespeak1 libffi-dev libftdi1 libgdata-common libgdict-common libgoa-1.0-common libgtksourceview2.0-common libguess1 libhal-storage1 libhal1
  libhiredis0.10 libhttp-parser2.1 libice-dev libjemalloc1 libjim0debian2 libjna-java libjs-underscore libksba8 libladr4 libllvm3.0 liblouis-data liblouis2 libmicrohttpd10
  libmowgli2 libmpg123-0 libmx-common libnfsidmap2 libnm-gtk-common liboauth0 libparted0 libpcrecpp0 libpcsc-perl libpff1 libpixman-1-dev libpthread-stubs0
  libpthread-stubs0-dev libpython2.6 libreadline-dev libreadline6-dev librxtx-java libshiboken1.1 libsm-dev libsmi2-common libsocialweb-common libsonic0 libssl-doc
  libtidy-0.99-0 libtinfo-dev libtinyxml2.6.2 libtre5 libwacom-common libwnck-3-common libx11-dev libx11-doc libxau-dev libxcb-render0-dev libxcb-shm0-dev libxcb1-dev
  libxcomposite-dev libxcursor-dev libxdamage-dev libxdmcp-dev libxext-dev libxfce4util-common libxfixes-dev libxi-dev libxinerama-dev libxml2-dev libxrandr-dev
  libxrender-dev libxres1 libxt-dev libzephyr4 linux-libc-dev llvm-3.0 llvm-3.0-dev llvm-3.0-runtime macchanger mc-data mobile-broadband-provider-info msgpack-python
  mtd-utils mtools nginx p7zip p7zip-full pidgin-data postgresql-common preview-latex-style prover9 python-adns python-argcomplete python-async python-bitarray
  python-bloomfilter python-bloomfiltermmap python-brlapi python-bs4 python-bson python-bson-ext python-clamd python-cluster python-concurrent.futures python-configobj
  python-d2to1 python-darts-lib-utils-lru python-dateutil python-easygui python-esmre python-flickrapi python-git python-gitdb python-gridfs python-guess-language
  python-halberd python-ipy python-jinja2 python-levenshtein python-libxslt1 python-lightblue python-louis python-magic python-markdown python-markupsafe
  python-matplotlib-data python-mechanize python-metaconfig python-msgpack python-ndg-httpsclient python-nltk python-ntlm python-oauth python-opengl python-paramiko
  python-pdfminer python-pexpect python-phply python-pip python-pycryptopp python-pyexiv2 python-pyexiv2-doc python-pygithub python-pymongo python-pymongo-ext
  python-pyparsing python-pypdf python-pyscard python-pysnmp4 python-pysnmp4-apps python-pysnmp4-mibs python-scipy python-sip python-smmap python-speechd python-stopit
  python-svn python-tblib python-tidylib python-tweepy python-usb python-vulndb redis-server ruby-ansi ruby-atomic ruby-buftok ruby-daemons ruby-dataobjects
  ruby-dataobjects-mysql ruby-dataobjects-postgres ruby-dataobjects-sqlite3 ruby-dm-core ruby-dm-do-adapter ruby-dm-migrations ruby-dm-sqlite-adapter ruby-em-websocket
  ruby-equalizer ruby-erubis ruby-eventmachine ruby-execjs ruby-faraday ruby-http ruby-http-parser.rb ruby-librex ruby-libv8 ruby-memoizable ruby-msfrpc-client
  ruby-msgpack ruby-multi-json ruby-multipart-post ruby-naught ruby-parseconfig ruby-rack ruby-rack-protection ruby-ref ruby-rubyzip ruby-simple-oauth ruby-sinatra
  ruby-term-ansicolor ruby-therubyracer ruby-thread-safe ruby-tilt ruby-twitter ruby-uglifier ruby-yajl smartmontools sound-theme-freedesktop sqlmap syslinux
  texlive-latex-extra texlive-latex-extra-doc texlive-pictures texlive-pictures-doc thin unetbootin-translations usb-modeswitch usb-modeswitch-data w3af-console
  x11proto-composite-dev x11proto-core-dev x11proto-damage-dev x11proto-fixes-dev x11proto-input-dev x11proto-kb-dev x11proto-randr-dev x11proto-render-dev
  x11proto-xext-dev x11proto-xinerama-dev xbrlapi xorg-sgml-doctools xsltproc xtrans-dev zenity-common
Use 'apt-get autoremove' to remove them.
The following packages will be REMOVED:
  accountsservice alacarte apktool arduino at-spi2-core audacious audacious-plugins baobab binwalk bluepot bluesnarfer bluez brasero brasero-common burpsuite caribou
  caribou-antler casefile cheese-common chirp colord consolekit creepy cups-pk-helper curlftpfs cutycapt dbpwaudit dconf-gsettings-backend dconf-service dconf-tools
  debhelper default-jdk default-jre desktop-base desktop-file-utils dex2jar dff dirbuster dissy driftnet dsniff edb-debugger empathy enchant eog ettercap-common
  ettercap-graphical evince evince-common evolution-data-server evolution-data-server-common fern-wifi-cracker file-roller filezilla florence gcalctool gconf-service
  gconf2 gcr gdm3 gdm3setup-daemon gedit gedit-common geoclue geoclue-hostip geoclue-localnet geoclue-manual geoclue-yahoo gettext ghost-phisher gimp
  gir1.2-accountsservice-1.0 gir1.2-atk-1.0 gir1.2-atspi-2.0 gir1.2-caribou-1.0 gir1.2-clutter-1.0 gir1.2-clutter-gst-1.0 gir1.2-cogl-1.0 gir1.2-coglpango-1.0
  gir1.2-evince-3.0 gir1.2-folks-0.6 gir1.2-freedesktop gir1.2-gck-1 gir1.2-gconf-2.0 gir1.2-gcr-3 gir1.2-gdkpixbuf-2.0 gir1.2-gee-1.0 gir1.2-gkbd-3.0 gir1.2-glib-2.0
  gir1.2-gmenu-3.0 gir1.2-gnomebluetooth-1.0 gir1.2-gnomekeyring-1.0 gir1.2-gst-plugins-base-0.10 gir1.2-gstreamer-0.10 gir1.2-gtk-2.0 gir1.2-gtk-3.0 gir1.2-gtkclutter-1.0
  gir1.2-gtksource-3.0 gir1.2-gtop-2.0 gir1.2-javascriptcoregtk-1.0 gir1.2-json-1.0 gir1.2-mutter-3.0 gir1.2-networkmanager-1.0 gir1.2-panelapplet-4.0 gir1.2-pango-1.0
  gir1.2-peas-1.0 gir1.2-polkit-1.0 gir1.2-soup-2.4 gir1.2-telepathyglib-0.12 gir1.2-telepathylogger-0.2 gir1.2-upowerglib-1.0 gir1.2-webkit-1.0 gir1.2-wnck-3.0
  gir1.2-xkl-1.0 gjs gkbd-capplet gksu glib-networking glib-networking-services gnome-applets gnome-applets-data gnome-bluetooth gnome-brave-icon-theme gnome-color-chooser
  gnome-colors-common gnome-contacts gnome-control-center gnome-core gnome-dictionary gnome-disk-utility gnome-font-viewer gnome-icon-theme gnome-icon-theme-extras
  gnome-icon-theme-symbolic gnome-keyring gnome-mag gnome-media gnome-online-accounts gnome-orca gnome-packagekit gnome-panel gnome-panel-data gnome-power-manager
  gnome-screensaver gnome-screenshot gnome-session gnome-session-bin gnome-session-fallback gnome-settings-daemon gnome-shell gnome-shell-common gnome-shell-extensions
  gnome-sushi gnome-system-log gnome-system-monitor gnome-terminal gnome-terminal-data gnome-themes-standard gnome-tweak-tool gnome-user-guide gnome-user-share gnuplot
  gnuplot-nox gparted graphviz greenbone-security-assistant gsettings-desktop-schemas gstreamer0.10-ffmpeg gstreamer0.10-gconf gstreamer0.10-nice gstreamer0.10-plugins-bad
  gstreamer0.10-plugins-base gstreamer0.10-plugins-good gstreamer0.10-plugins-ugly gstreamer0.10-pulseaudio gstreamer0.10-x gtk-theme-config gtk2-engines
  gtk2-engines-murrine gtk2-engines-pixbuf gtk3-engines-unico gucharmap guymager gvfs gvfs-backends gvfs-bin gvfs-common gvfs-daemons gvfs-libs hal hexorbase hydra-gtk
  icedtea-netx iceweasel imagemagick intltool-debian irqbalance javasnoop johnny jsql kali-defaults kali-desktop-common kali-desktop-gnome kali-linux katepart kde-runtime
  kdebase-runtime kdelibs-bin kdelibs5-plugins kdoctools keepnote killerbee konsole leafpad libaccountsservice0 libatk-adaptor libatk-adaptor-data libatk-bridge2.0-0
  libatk-wrapper-java-jni libatk1.0-0 libatkmm-1.6-1 libatspi1.0-0 libatspi2.0-0 libattica0 libaudclient2 libaudcore1 libavahi-glib1 libavahi-gobject0 libavahi-ui-gtk3-0
  libbonobo2-0 libbonoboui2-0 libbrasero-media3-1 libcairo-gobject2 libcamel-1.2-33 libcanberra-gtk-module libcanberra-gtk0 libcanberra-gtk3-0 libcanberra-gtk3-module
  libcanberra-pulse libcaribou-gtk-module libcaribou-gtk3-module libcaribou0 libchamplain-0.12-0 libchamplain-gtk-0.12-0 libcheese-gtk21 libcheese3 libclutter-1.0-0
  libclutter-gst-1.0-0 libclutter-gtk-1.0-0 libclutter-imcontext-0.1-0 libclutter-imcontext-0.1-bin libcluttergesture-0.0.2-0 libcogl-pango0 libcogl9 libcolord1 libcroco3
  libdbus-glib-1-2 libdbusmenu-qt2 libdconf0 libebackend-1.2-2 libebook-1.2-13 libecal-1.2-11 libedata-book-1.2-13 libedata-cal-1.2-15 libedataserver-1.2-16
  libedataserverui-3.0-1 libenchant1c2a libevdocument3-4 libevview3-3 libfarstream-0.1-0 libfile-mimeinfo-perl libfluidsynth1 libfolks-eds25 libfolks-telepathy25
  libfolks25 libgail-3-0 libgail-common libgail18 libgck-1-0 libgconf-2-4 libgconf2-4 libgcr-3-1 libgdata13 libgdict-1.0-6 libgdk-pixbuf2.0-0 libgdu-gtk0 libgdu0 libgee2
  libgegl-0.2-0 libgeoclue0 libgeocode-glib0 libgimp2.0 libgirepository-1.0-1 libgjs0b libgksu2-0 libglade2-0 libglademm-2.4-1c2a libglib-perl libglib2.0-0 libglib2.0-bin
  libglibmm-2.4-1c2a libgmime-2.6-0 libgnome-bluetooth10 libgnome-desktop-3-2 libgnome-keyring0 libgnome-mag2 libgnome-media-profiles-3.0-0 libgnome-menu-3-0 libgnome2-0
  libgnome2-common libgnomecanvas2-0 libgnomekbd-common libgnomekbd7 libgnomeui-0 libgnomevfs2-0 libgnomevfs2-common libgnomevfs2-extra libgoa-1.0-0 libgsf-1-114
  libgssdp-1.0-3 libgstreamer-plugins-bad0.10-0 libgstreamer-plugins-base0.10-0 libgstreamer0.10-0 libgtk-3-0 libgtk-3-bin libgtk-3-common libgtk2-perl libgtk2.0-0
  libgtk2.0-bin libgtkmm-2.4-1c2a libgtkmm-3.0-1 libgtksourceview-3.0-0 libgtksourceview2.0-0 libgtkspell0 libgtop2-7 libgucharmap-2-90-7 libgudev-1.0-0 libgupnp-1.0-4
  libgupnp-igd-1.0-4 libgusb2 libguytools2 libgvc5 libgweather-3-0 libgweather-common libgxps2 libidl0 libimobiledevice2 libjavascriptcoregtk-1.0-0
  libjavascriptcoregtk-1.0-dev libjavascriptcoregtk-3.0-0 libjson-glib-1.0-0 libkatepartinterfaces4 libkcmutils4 libkde3support4 libkdeclarative5 libkdecore5 libkdesu5
  libkdeui5 libkdewebkit5 libkdnssd4 libkemoticons4 libkfile4 libkhtml5 libkidletime4 libkio5 libkjsapi4 libkjsembed4 libkmediaplayer4 libknewstuff3-4 libknotifyconfig4
  libkntlm4 libkonq-common libkonq5abi1 libkparts4 libkpty4 libkrosscore4 libktexteditor4 liblensfun0 liblqr-1-0 libmagickcore5 libmagickcore5-extra libmagickwand5 libmdb2
  libmdbsql2 libmeanwhile1 libmetacity-private0a libmimic0 libmission-control-plugins0 libmms0 libmutter0 libmx-1.0-2 libmx-bin libnautilus-extension1a libnepomuk4
  libnepomukquery4a libnepomukutils4 libnice10 libnids1.21 libnm-glib-vpn1 libnm-glib4 libnm-gtk0 libnm-util2 libnotify4 libntrack-qt4-1 libopenvas8 liborbit2
  libosmgpsmap2 libpackagekit-glib2-14 libpanel-applet-4-0 libpango-perl libpango1.0-0 libpangomm-1.4-1 libpeas-1.0-0 libphonon4 libplasma3 libpolkit-agent-1-0
  libpolkit-backend-1-0 libpolkit-gobject-1-0 libpolkit-qt-1-1 libpoppler-glib8 libpulse-mainloop-glib0 libpurple-bin libpurple0 libpyside1.1 libqca2 libqscintilla2-8
  libqt4-dbus libqt4-declarative libqt4-designer libqt4-help libqt4-network libqt4-opengl libqt4-qt3support libqt4-script libqt4-scripttools libqt4-sql libqt4-sql-mysql
  libqt4-sql-sqlite libqt4-svg libqt4-test libqt4-xml libqt4-xmlpatterns libqtassistantclient4 libqtcore4 libqtdbus4 libqtgui4 libqtwebkit4 libqwt5-qt4 librest-0.7-0
  librest-extras-0.7-0 librsvg2-2 librsvg2-common libseed-gtk3-0 libsocialweb-client2 libsocialweb-service libsocialweb0 libsolid4 libsoprano4 libsoup-gnome2.4-1
  libsoup2.4-1 libspeechd2 libtelepathy-farstream2 libtelepathy-glib0 libtelepathy-logger2 libthreadweaver4 libtotem-plparser17 libtracker-extract-0.14-0
  libtracker-miner-0.14-0 libtracker-sparql-0.14-0 libunique-3.0-0 libupower-glib1 libvte-2.90-9 libwacom2 libwebkitgtk-1.0-0 libwebkitgtk-3.0-0 libwireshark3 libwiretap3
  libwmf0.2-7 libwnck-3-0 libwsutil3 libwxgtk2.8-0 libxfce4util-bin libxfce4util4 libxfconf-0-2 libxklavier16 libyelp0 magictree maltego maltego-teeth mc mdbtools metacity
  metacity-common modemmanager mousetweaks mtpfs murrine-themes mutter-common nautilus nautilus-data nautilus-open-terminal nautilus-sendto nautilus-sendto-empathy
  network-manager network-manager-gnome notification-daemon numix-gtk-theme obex-data-server obexd-client ohrwurm openjdk-6-jdk openjdk-6-jre openjdk-7-jdk openjdk-7-jre
  openjdk-7-jre-headless openvas openvas-cli openvas-manager openvas-scanner ophcrack oscanner packagekit packagekit-backend-aptcc packagekit-tools paros patator
  pcsc-tools phonon phonon-backend-vlc pkg-config plasma-scriptengine-javascript po-debconf policykit-1 policykit-1-gnome protos-sip proxystrike pulseaudio
  pulseaudio-module-x11 python-dbus python-gi python-gi-cairo python-glade2 python-gobject python-gobject-2 python-gtk2 python-gtksourceview2 python-gtkspell
  python-matplotlib python-osmgpsmap python-packagekit python-pyatspi python-pyatspi2 python-pyqtgraph python-pyside python-pyside.phonon python-pyside.qtcore
  python-pyside.qtdeclarative python-pyside.qtgui python-pyside.qthelp python-pyside.qtnetwork python-pyside.qtopengl python-pyside.qtscript python-pyside.qtsql
  python-pyside.qtsvg python-pyside.qttest python-pyside.qtuitools python-pyside.qtwebkit python-pyside.qtxml python-qscintilla2 python-qt4 python-qt4-gl python-qt4-phonon
  python-rfidiot python-rsvg python-webkit python-wxgtk2.8 python-wxtools python-xdot qdbus rifiuti2 sctpscan set shared-mime-info smali soprano-daemon spectools
  speech-dispatcher spooftooph sqlitebrowser telepathy-gabble telepathy-haze telepathy-logger telepathy-mission-control-5 telepathy-salut tracker tracker-extract
  tracker-gui tracker-miner-fs tracker-utils truecrypt tshark udisks ufraw-batch ultracopier unetbootin upower vim-gtk vino vlc vlc-plugin-notify w3af webscarab webshag
  webslayer wireshark wireshark-common wkhtmltopdf xfconf yakuake yelp yersinia zaproxy zenity zenmap zim

It basically tries to remove my whole system... I pressed n to abort. What do I do to fix this mess?

On executing the suggested dpkg -l|grep libc6 I get this:

ii  libc6:amd64                             2.19-18                                amd64        GNU C Library: Shared libraries
rc  libc6-i386                              2.13-38+deb7u8                         amd64        Embedded GNU C Library: 32-bit shared libraries for AMD64

The amd64 package is the one I installed manually

[EDIT] This is becoming a serious problem, whenever I try to start a program like gedit, or gimp it gives the following error:

gimp: error while loading shared libraries: libffi.so.6: cannot open shared object file: No such file or directory

After doing the following steps my problem disappeared, or so I thought. First I added deb http://ftp.nl.debian.org/debian sid main to the /etc/apt/sources.list file, and run apt-get update and then apt get upgrade

Everything seemed to work fine, but when I tried to restart it crashed. After a minute with a black screen a message appeard that I should contact my system administrator. What should I do?

  • Have you tried removing the package you have installed and restoring the original? – YoMismo May 7 '15 at 15:33
  • The package is libc6, is it safe to do so? – Rumanoid May 7 '15 at 15:35
  • Have you removed the original libc6 package? – YoMismo May 7 '15 at 15:35
  • I upgraded it, using a .deb I downloaded from the debian repo – Rumanoid May 7 '15 at 15:37
  • do a dpkg -l|grep libc6 and check if you still have the previous version.The problem is that you have unmet dependencies and the reason for that is your installation from outside apt. I don't know about kali, but in debian it is better the way used in the next link, since that method installs the dependencies when needed. unix.stackexchange.com/questions/107689/… – YoMismo May 7 '15 at 15:42

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.