7

My notebook does not have a hardware button to disable wireless. But NetworkManager and rfkill see wireless as hard blocked. Wicd and iwconfig works well.

Is there any way to disable hard block check in driver or network manager? Or make rfkill to show right state?

Driver is ath9k. Wireless card is Qualcomm Atheros AR9565

  • What you need is not to get NM to believe that the wifi is enabled, but to actually enable the wifi. Please tell us the output of rfkill list (install the rfkill package if necessary, though maybe you can use systemd's built-in support if you're using systemd) and find /sys -name rfkill. What distribution are you using and what distribution? – Gilles May 7 '15 at 20:31
  • @Gilles, rfkill report that cards are hardblocked, debian jessie, lenovo g50-30 – eri May 8 '15 at 5:44
  • phy0 is not blocked – eri May 8 '15 at 5:47
1

I'm blacklisted ideapad_laptop module and now seems to all works fine!

echo blacklist ideapad_laptop > /etc/modprobe.d/bad_rfkill.conf
depmod -ae
update-initramfs -u

And rebooted. What i disabled with removing this module except wireless interface?

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.