1

When I login to the system I have few Nemo windows open.

I did it few weeks ago, and probably forgot to close at shut down.
But now Mint remember my open application and always open it after start up:

start up applications

UPDATE:

Of course, I checked Settings => Startup Application.

It doesn't contain any file browsers. It contains only desired application for me.

UPDATE_2:

I checked solution mentioned here Xfce4 mysteriously starts file browser upon login.

And can conclude that it doesn't work for Cinnamon environment. ~/.cache/ doesn't contain any sessions folder:

session folder

How to get rid of this start up application?

  • @JID What do you exactly mean? – nazar_art May 7 '15 at 12:48
  • 1
    @JID, the init process takes care of starting services at boot time and when changing runlevels. It does not start applications when you login into a desktop manager session. nazar_art wants to know how he can prevent the desktop manager from opening a file browser while logging in. – Lambert May 7 '15 at 12:52
  • @nazar_art, have a look at menu / preferences / startup applications, it might be listed there – Lambert May 7 '15 at 12:54
  • @Lambert Fair enough. I misunderstood what they meant by startup, i presumed booting. – user78605 May 7 '15 at 12:54
  • 1
    @nazar_art I think it's a duplicate of unix.stackexchange.com/questions/196111/… – apaul May 7 '15 at 13:17
1

I think you were very close.

Just go into Settings => Startup Programs and then click on the Options tab.

There, you will see a checkbox saying

Automatically remember running applications when logging out

Just uncheck it.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.