6

I'm trying to change menu shortcuts in the E-mail client Evolution, specifically removing the "send message" via "Ctrl-Enter" shortcut, but can't figure out how.

My system is rather new:

  • Debian 8 Jessie 64bit
  • Gnome 3.14.1
  • Evolution 3.12.9

I searched the net for hours and tried the following solutions. Unfortunately, none of them worked:

  1. use gconf-editor to set desktop->gnome->interface->can_change_accels to true. Then restart Evolution, compose a new message, mouse-hover over the menu item and press a new key-combination
  2. Same as solution 1, but use dconf-editor to set org->gnome->desktop->interface->can-change-accels to true
  3. Same as solution 1, but use gsettings set org.gnome.desktop.interface can-change-accels true
  4. Edit ~/.config/evolution/accels. Uncomment "Actions/mailto/send-message" and assign a new key-binding.
  5. Looked for other config files in various locations, but they didn't exist on my system: ~/.evolution/, ~/.gnome2/accels/evolution
  6. Evolution itself doesn't seem to have any menu/option for changing the shortcuts

I hope someone can help me out with this one.

1
  • I've got the same problem! Did you find any solution?
    – g4b0
    Mar 17, 2017 at 15:42

1 Answer 1

2

I solved editing ~/.config/evolution/accels , removing the initial ";" and specifying the new shortcut. Evolution must be closed, since it apparently rewrite the file on closure.

I found the solution in comments here: https://major.io/2015/11/27/custom-keyboard-shortcuts-for-evolution-in-gnome/

1
  • There's no ~/.config/evolution/accels file. At least not with a 3.44.2 Evolution version. I also tried to search for the gtk_accel_path keyword in the entire ~/.config/evolution/ directory and there were no matches 🤷‍♂️
    – Hi-Angel
    Jun 27, 2022 at 8:20

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .