6

I've got a MSI WD-60 laptop running Gentoo. It has one of those 3840x2160 screens so I've had to setup Gnome/Firefox/IntellJ to double their DPI for anything to be readable. It all works fine except for the framebuffer during boot.

I've using CONFIG_FB_EFI in my kernel, so I'm assuming the kernel is using that for its framebuffer driver. I've given grub a larger font and lower resolution using:

GRUB_GFXMODE=1920x1080
GRUB_GFXPAYLOAD_LINUX=keep
GRUB_FONT="/boot/grub/fonts/DejaVuSans30.pcf"

Grub2 looks fine and is in 1920x1080, but after I select my Kernel, the mode switches back to native and my framebuffer text is tiny. I also tried the older vga=795 option, but that doesn't seem to work either.

It's not that big a deal, but I do have LUKS encryption so the prompt in my initram is pretty tiny. Is there anyway to get my boot sequence to either use a larger font or higher DPI or lower resolution during bootup? Is there a kernel option or argument I'm missing that specifically for the EFI framebuffer?

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.