3

I'm currently dual booting Linux Mint and Windows 8 on a machine with dual ASUS nVidia GTX 770s running in SLI (on an ASUS Z97-Deluxe motherboard). Everything works fine on the Windows side, but when I boot from Windows to Linux the screens both go dark and stay dark as soon as I'm out of GRUB. If I unplug the second monitor then everything boots up like normal on the first monitor, and then oddly enough if I plug the second monitor back in and then reboot the machine from Linux back into Linux everything works fine and I can use both monitors. Obviously rebooting the machine twice and having to crawl under the desk and unplug/plugin a cable is less than ideal for my "switch OS" process. Thanks in advance for any help that you're able to offer!

  • When you have the 2 monitors connected, is there something written to /var/log/messages or syslog? – ott-- May 9 '15 at 23:38
  • Try disabling acpi in /etc/default/grub change this variable GRUB_CMDLINE_LINUX_DEFAULT="quiet splash acpi=off", and reboot. Just add acpi=off to whatever other directives existed already. I had a similar issue but without two monitors. The power management and a few other features will be controlled by the BIOS firmware after the next reboot. If this "solves" the problem, then the issue is with GNU/Linux software, probably drivers. The fact the Windows works already suggests this. So the problem wont be solved, you need to either use the correct divers, or bugs need fixing, or both. – Overloaded_Operator May 12 '15 at 16:44
  • Make sure to sudo update-grub2 after modifying the file and before rebooting, I forgot to say that. I am on a similar boat and have content/lazy since I can boot and shutdown without black screen or random reboots, but I would like to use acpi, so I should probably think about filling a report myself ( I had been blaming my hardware for awhile). – Overloaded_Operator May 12 '15 at 16:46
  • @ott-- I just rebooted with both monitors and at a glance, it doesn't look like anything under /var/log has been touched. – Tyson May 13 '15 at 4:47
  • @Overloaded_Operator I tried following your suggestion and I got an error when I ran update-grub2, not exactly sure what the issue is. I haven't touched this stuff for a while, but I remember having to play around with grub-customizer back in the day to get Windows 8 booting correctly. – Tyson May 13 '15 at 4:53

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.