0

I have a Raspberry Pi that sets up an SSH tunnel with my VPS so that I can access several things remotely. My Pi forwards its local port 80 to my VPS's port 3180, so I can access it via http://domain.com:3180. My domain, however, is automatically using SSL/TLS and doesn't allow me to bypass this unless I go to the IP address instead of the domain name. I like this functionality, but I get a "Connection Dropped" error when any browser attempts to access the SSL/TLS page.

How can I either set up the connection so that I can connect to the Pi's web server via my VPS's domain name/port using SSL/TLS (preferred method), or disable HTTPS forwarding just for that port (less preferred method)?

The Pi is running Raspbian Wheezy, and the VPS is on Ubuntu Server 15.04.

My Pi creates the connections with this command (three separate ports are forwarded, the port numbers are just changed accordingly):

ssh -f -N -R 3180:localhost:80 -i /home/user/.ssh/id_rsa -p 22 user@IP_ADDRESS
  • Is using SSL/TLS on the Raspberry Pi webserver an option? – FloHimself May 7 '15 at 6:38
  • @FloHimself That's something I hadn't considered. I'll try adding the domain's certificates to the Pi and I'll forward port 443 instead of 80. I'll let you know what happens. – vaindil May 9 '15 at 15:50

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.