I downloaded and extracted the VSCode zip. I see the Code binary file, but doubleclicking it in my file manager does nothing. I also tried ./Code in console, but I only get bash: ./Code: cannot execute binary file. Just typing Code causes bash: Code: command not found. My guess is that it might be a dependancy issue, but I don't even know where to start.

I tried to chmod 777 the files and folders, but no luck.

uname -a: Linux crunchbang 3.2.0-4-686-pae #1 SMP Debian 3.2.41-2 i686 GNU/Linux

Running strace produces:

$ strace ./Code
execve("./Code", ["./Code"], [/* 25 vars */]) = -1 ENOEXEC (Exec format error)
dup(2)                                  = 3
fcntl64(3, F_GETFL)                     = 0x2 (flags O_RDWR)
fstat64(3, {st_mode=S_IFCHR|0620, st_rdev=makedev(136, 2), ...}) = 0
mmap2(NULL, 4096, PROT_READ|PROT_WRITE, MAP_PRIVATE|MAP_ANONYMOUS, -1, 0) = 0xb76ec000
_llseek(3, 0, 0xbf9d8a88, SEEK_CUR)     = -1 ESPIPE (Illegal seek)
write(3, "strace: exec: Exec format error\n", 32strace: exec: Exec format error
) = 32
close(3)                                = 0
munmap(0xb76ec000, 4096)                = 0
exit_group(1)                           = ?

Running file produces

$ file Code
Code: ELF 64-bit LSB executable, x86-64, version 1 (SYSV), dynamically linked (uses shared libs), for GNU/Linux 2.6.24, BuildID[sha1]=0x7a776e173e68b15269ebd273dd987b526f5ebcae, stripped

I found the solution based on another Q&A;

So based on the file the Code is a 64bit executable and based on uname my system apparently is 32bit, which is different from what I thought.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.