1

I'm using Time Machine File System (tmfs), which is an extension of FUSE, to read the data on a backup drive and hopefully make accessible from a Windows machine:

Create a shared folder you can write to / read in both Linux and Windows -

sudo mount -t cifs -o username=<WinUser>,uid=<CentOSUser>,gid=wheel,ip=192.168.0.104 //hp1/Users/<WinUser>/p9230-stub /home/<CentOSUser>/p230-stub

Then funnel a FUSE directory into it, which you can read as a normal user in CentOS -

sudo tmfs /media/<CentOSUser>/p9230-Partn1/ /home/<CentOSUser>/p9230-stub/Partn1-viatmfs/ -ouid=$(id -u),gid=$(id -g),allow_other

Although it mounts into my Windows share folder, and I can verify this with cd and ls, the folder won't appear when I'm inside Windows. The only difference I can see between small files I move to the shared folder myself and my fuse folder is that the latter is owned by root and the former by the normal CentOS user.

Is it possible to re-jig these commands so the FUSE folder gets picked up and shared?

1

You're looking for the mount option -o allow_others. This allows other users besides the owner of the fuse-process to use the fs (and thus the user of your smbd too).

If you haven't set user_allow_other in /etc/fuse.conf you won't be able to use that option unless you're root.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.