My OS is Slackware 13.37 64-bit. I have two monitors. Primary one supports 1920x1200 and the secondary one 1280x1024. I use this line to enable dual monitors in "non-clone" mode:

xrandr --output HDMI1 --primary --output VGA1 --left-of HDMI1

After I do this, the secondary monitor stops cloning the primary one and acquires its own virtual desktop. However, the primary gets the resolution 1280x1024. After I explicitly set it back to 1920x1200, the secondary monitor gets false info about its boundaries. The bottom part gets a bit longer such that the cursor disappears if I move too much to the bottom (as if there is still space below the monitor edge).

How can I solve this issue?


user@pc:~$ xrandr -q
Screen 0: minimum 320 x 200, current 3200 x 1200, maximum 8192 x 8192
VGA1 connected 1280x1024+0+176 (normal left inverted right x axis y axis) 376mm x 301mm
   1280x1024      60.0*+   75.0  
   1152x864       75.0  
   1024x768       75.1     60.0  
   800x600        75.0     60.3  
   640x480        75.0     60.0  
   720x400        70.1  
HDMI1 connected 1920x1200+1280+0 (normal left inverted right x axis y axis) 518mm x 324mm
   1920x1200      60.0*+
   1920x1080      50.0     60.0  
   1600x1200      60.0  
   1680x1050      60.0  
   1280x1024      60.0  
   1440x900       59.9  
   1280x960       60.0  
   1280x800       59.8  
   1280x720       50.0     60.0  
   1024x768       60.0  
   800x600        60.3     56.2  
   720x576        50.0  
   720x480        59.9  
   640x480        60.0  
DP1 disconnected (normal left inverted right x axis y axis)
  • 1
    For future reference, please don't crosspost. The SU version of your post was deleted Commented Sep 6, 2011 at 0:48
  • Can you post the output of xrandr -q and /etc/X11/xorg.conf
    – nopcorn
    Commented Nov 21, 2011 at 6:40
  • I added the output. Can't post xorg.conf, sinc I'm now working on Ubuntu 11.10. Here I have the same problem but with the upper border.
    – azerIO
    Commented Nov 21, 2011 at 11:18

2 Answers 2


One thing you can try:

If you run xrandr by itself, it will give you a list of resolutions for each monitor.

Observe the one you want for each monitor.
Now on your xrandr line that you gave above, you can also set the resolution:

xrandr --verbose --output HDMI1 --mode 1920x1200 xrandr --verbose --output VGA1 --mode 1280x1024 xrandr --verbose --output HDMI1 --primary --output VGA1 --left-of HDMI1

  • 1
    Doesn't help. It just treats the down bottom of the VGA screen as if its border is deeper below. The rest (up, left, right) borders are correct. No idea what to do.
    – azerIO
    Commented Sep 23, 2011 at 11:23

take a look at this question, I think it could also solve your problem:

first run

$ xrandr

this will give output like this:

Screen 0: minimum 320 x 200, current 5120 x 1080, maximum 8192 x 8192
HDMI1 connected 2560x1080+2560+0 (normal left inverted right x axis y axis) 677mm x 290mm 
   1920x1080     60.00*  
   1680x1050     59.88  
   1600x900      59.98  

HDMI2 connected 2560x1080+0+0 (normal left inverted right x axis y axis) 677mm x 290mm
   2560x1080     60.00*+
   2560x1080_60.00  59.98  
   1920x1080     60.00    50.00    59.94    30.00    29.97  
   1920x1080i    60.00    50.00    59.94  

to add 2560x1080 to HDMI1 first run the next command

$ cvt 2560 1080

sample output:

2560x1080 59.98 Hz (CVT) hsync: 67.17 kHz; pclk: 230.00 MHz
Modeline "2560x1080_60.00"  230.00  2560 2720 2992 3424  1080 1083 1093 1120 -hsync +vsync

now you need to use this output to test the resolution and than add the settings for use in the next sessions.


$ xrandr --newmode "2560x1080_60.00"  230.00  2560 2720 2992 3424  1080 1083 1093 1120 -hsync +vsync
$ xrander --addmode HDMI1 2560x1080_60.00

if it works you can add it to the xorg configuration

$ vim /etc/X11/xorg.conf.d/40-monitor.conf

Section "Monitor"
    Identifier "HDMI1"
    Modeline "2560x1080_60.00"  230.00  2560 2720 2992 3424  1080 1083 1093 1120 -hsync +vsync
    Option "PreferredMode" "2560x1080"

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .