1

I am trying to backup my Synology NAS to my old NAS. The old NAS has to be an rsync compatible server (according to Synology), and the original OS didn't support it. Fortunately OpenBSD supports my NAS ('landisk', well done!), and I managed to get rsync running in daemon mode.

I read the option to launch rsync via inetd. I thought this would be the best option. I followed the instructions in the man pages. Everything is done under the root account. The line

rsync           873/tcp

was already in my /etc/services.

I created /etc/inetd.conf and added the line

rsync   stream  tcp     nowait  root   /usr/local/bin/rsync rsyncd --daemon

Then I had to send a HUP signal to inetd. But with ps -A I didn't see inetd running.

So I added the line

inetd=YES

to rc.conf.local, which looks now like this:

ntpd_flags=
inetd=YES

When I enter inetd at the CLI everything works fine. But when I reboot the NAS, inetd is not running. What am I missing?

1

The correct way to handle services and daemons on an OpenBSD system (since OpenBSD 5.7) is by using rcctl(8):

To enable inetd and ntpd (assuming you have configured doas to give you superuser rights):

$ doas rcctl enable inetd
$ doas rcctl enable ntpd

To start inetd and ntpd without rebooting (requires a valid /etc/inetd.conf and /etc/ntpd.conf):

$ doas rcctl start inetd
$ doas rcctl start ntpd

The rsync port comes with /etc/rc.d/rsyncd, which means that you may enable and start the rsync daemon through

$ doas rcctl enable rsyncd
$ doas rcctl start rsyncd

This requires that you first create /etc/rsyncd.conf.

0

Because of the lack of reactions, I posted my question on another forum.

And there I got the answer!

This is what my /etc/rc.conf.local now looks like:

ntpd_flags=
inetd_flags=
inetd=YES

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.