1

I need to upgrade OPENSSL from 0.9.8j-0.50.1 -> 1.0.2a on a server that is running sles11 sp3 for dynamically linking into my program.

Steps followed for upgrade my build environment(sles11sp3):

1.Downloaded the package from https://www.openssl.org/source/ and follows as below,

a)wget https://www.openssl.org/source/openssl-1.0.2a.tar.gz b)./config -fPIC shared --prefix=/usr --openssldir=/etc/ssl c)make d)make install INSTALL_PREFIX=/home/Release/openssl/ e)cd /home/Release/openssl/ d)ls -l f)cp -rf * /

2.Now if execute openssl version,its shows as below(Expected),

   OpenSSL> version
   OpenSSL 1.0.2a 19 Mar 2015
   OpenSSL> 

3.After this,compiling my program(which has SNMP,CURL),i am seeing two compilation warning below,

/usr/lib64/gcc/x86_64-suse-linux/4.3/../../../../x86_64-suse-linux/bin/ld: warning: libcrypto.so.0.9.8, needed by /usr/lib64/libnetsnmpagent.so, may conflict with libcrypto.so.1.0.0

  /usr/lib64/gcc/x86_64-suse-linux/4.3/../../../../x86_64-suse-linux/bin/ld: warning: libssl.so.0.9.8, needed by /usr/lib64/libcurl.so, may conflict with libssl.so.1.0.0

4.So fixing this warning, createad following symlink in /usr/lib64 directory as below,

cd /usr/lib64 ln -sf libssl.so.1.0.0 libssl.so.0.9.8 ln -sf libcrypto.so.1.0.0 libcrypto.so.0.9.8

5.Now i am not seeing any compilation warning,and also my build rpm got generated(myprogram.rpm).

6.Same steps(except 3) followed in my enterprise server(hereonly need to run my program) which is running on same sles11 sp3.

rpm -ivh myprogram.rpm
   error:Failed dependencies:
   libcrypto.so.1.0.0()(64bit) is needed by myprogram
   libssl.so.1.0.0()(64bit) is needed by myprogram

Kindly suggest me where i am doing wrong or missing anything.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.