6

The terminal has gone invisible , although I can type commands and they get executed: enter image description here

Even some firefox download dropdowns are invisible, I can click the items in the drop down list but the list itself is invisible(see the down arrow highlighted but the drop down list is invisible): enter image description here

Some system details:

~> stty --all
speed 38400 baud; rows 24; columns 80; line = 0;
intr = ^C; quit = ^\; erase = ^?; kill = ^U; eof = ^D; eol = M-^?; eol2 = M-^?;
swtch = M-^?; start = ^Q; stop = ^S; susp = ^Z; rprnt = ^R; werase = ^W;
lnext = ^V; flush = ^O; min = 1; time = 0;
-parenb -parodd cs8 hupcl -cstopb cread -clocal -crtscts
-ignbrk brkint -ignpar -parmrk -inpck -istrip -inlcr -igncr icrnl -ixon -ixoff
-iuclc ixany imaxbel iutf8
opost -olcuc -ocrnl onlcr -onocr -onlret -ofill -ofdel nl0 cr0 tab0 bs0 vt0 ff0
isig icanon iexten echo echoe echok -echonl -noflsh -xcase -tostop -echoprt
echoctl echoke


~ # sudo inxi -U
Starting inxi self updater.
Currently running inxi version number: 2.2.19
Current version patch number: 00
Updating inxi in /usr/bin using svn server as download source...
Successfully updated to svn server version: 2.2.19
New svn server version patch number: 00
To run the new version, just start inxi again.

    Aspire-5745 ~ # inxi -Fxz
System: Host: -Aspire-5745 Kernel: 3.13.0-37-generic x86_64 (64 bit gcc: 4.8.2)
Desktop: Cinnamon 2.4.6 (Gtk 3.10.8~8+qiana)
Distro: Linux Mint 17.1 Rebecca
Machine: System: Acer (portable) product: Aspire 5745 v: V1.19
Mobo: Acer model: JV51_CP Bios: INSYDE v: V1.19 date: 22/03/2011
CPU: Dual core Intel Core i5 M 460 (-HT-MCP-) cache: 3072 KB
flags: (lm nx sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx) bmips: 10109
clock speeds: max: 2534 MHz 1: 1199 MHz 2: 1199 MHz 3: 1199 MHz
4: 2534 MHz
Graphics: Card: Intel Core Processor Integrated Graphics Controller
bus-ID: 00:02.0
Display Server: X.org 1.15.1 drivers: intel (unloaded: fbdev,vesa)
tty size: 80x24 Advanced Data: N/A for root
Audio: Card Intel 5 Series/3400 Series High Definition Audio
driver: snd_hda_intel bus-ID: 00:1b.0
Sound: Advanced Linux Sound Architecture v: k3.13.0-37-generic
Network: Card-1: Qualcomm Atheros AR8151 v1.0 Gigabit Ethernet
driver: atl1c v: 1.0.1.1-NAPI port: 2000 bus-ID: 01:00.0
IF: eth0 state: up speed: 100 Mbps duplex: full mac: 
Card-2: Broadcom BCM43225 802.11b/g/n driver: wl bus-ID: 02:00.0
IF: wlan0 state: down mac: 
Drives: HDD Total Size: 500.1GB (82.3% used)
ID-1: /dev/sda model: Hitachi_HTS54505 size: 500.1GB temp: 36C
Partition: ID-1: / size: 23G used: 8.7G (40%) fs: ext4

I remember that I may have tried to unsuccessfully install Pycharm and SDL libraries before this happened. This happened after the system hanged and after I restarted my system I got this problem which is not going away. I tried a lot of things like restarting , changin theme colors, resetting terminal profile\colors\transparency etc post to various forums etc. but nothing worked.

Running sudo debsums -c:

/usr/share/initramfs-tools/scripts/casper-bottom/01integrity_check
/usr/share/initramfs-tools/scripts/casper-bottom/15autologin
/usr/share/cups/data/default-testpage.pdf
/usr/share/applications/evince.desktop
/usr/lib/firefox/browser/defaults/preferences/vendor-firefox.js
/usr/lib/firefox/distribution/distribution.ini
/usr/lib/firefox/distribution/searchplugins/locale/en-US/amazondotcom.xml
/usr/lib/firefox/distribution/searchplugins/locale/en-US/duckduckgo.xml
/usr/lib/firefox/distribution/searchplugins/locale/en-US/wikipedia.xml
/usr/lib/firefox/distribution/searchplugins/locale/en-US/yahoo.xml
/usr/lib/firefox/distribution/searchplugins/locale/en-GB/amazon-en-GB.xml
/usr/lib/firefox/distribution/searchplugins/locale/en-GB/chambers-en-GB.xml
/usr/lib/firefox/distribution/searchplugins/locale/en-GB/duckduckgo.xml
/usr/lib/firefox/distribution/searchplugins/locale/en-GB/wikipedia.xml
/usr/lib/firefox/distribution/searchplugins/locale/en-ZA/amazondotcom.xml
/usr/lib/firefox/distribution/searchplugins/locale/en-ZA/duckduckgo.xml
/usr/lib/firefox/distribution/searchplugins/locale/en-ZA/wikipedia.xml
/usr/share/icons/HighContrast/16x16/places/start-here.png
/usr/share/icons/HighContrast/22x22/places/start-here.png
/usr/share/icons/HighContrast/24x24/places/start-here.png
/usr/share/icons/HighContrast/32x32/places/start-here.png
/usr/share/icons/HighContrast/48x48/places/start-here.png
/usr/share/icons/HighContrast/scalable/places/start-here.svg
/usr/share/icons/gnome/16x16/places/ubuntu-logo.png
/usr/share/icons/gnome/22x22/places/ubuntu-logo.png
/usr/share/icons/gnome/24x24/places/ubuntu-logo.png
/usr/share/icons/gnome/32x32/places/ubuntu-logo.png
/usr/share/icons/gnome/scalable/places/ubuntu-logo.svg
/usr/share/applications/itweb-settings.desktop
/usr/bin/inxi
/usr/share/applications/libreoffice-math.desktop
/usr/lib/linuxmint/common/configobj.pyc
/usr/lib/linuxmint/mintInstall/Classes.pyc
/usr/lib/linuxmint/mintInstall/widgets/__init__.pyc
/usr/lib/linuxmint/mintInstall/widgets/pathbar2.pyc
/usr/lib/linuxmint/mintInstall/widgets/rgb.pyc
/usr/lib/linuxmint/mintInstall/widgets/searchentry.pyc
/usr/share/applications/openjdk-7-policytool.desktop
/usr/share/sounds/freedesktop/stereo/device-added.oga
/usr/share/sounds/freedesktop/stereo/device-removed.oga
/usr/share/polkit-1/actions/com.ubuntu.pkexec.synaptic.policy
/usr/share/applications/vino-preferences.desktop
/usr/share/applications/yelp.desktop
  • 1
    can you explain how it went invisible? And some more info like when this thing can be reproducable? – Thushi May 7 '15 at 7:13
  • 1
    @Thushi see the last para in above updated – unixit May 7 '15 at 7:22
  • Have you tried reinstalling gnome-terminal? purge and reinstall the terminal – Thushi May 7 '15 at 7:28
  • @Thushi yes I uninstalled and reinstalled it but same problem, xterm is working though – unixit May 7 '15 at 7:58
  • 1
    I also installed sakura in synaptic but same problem, only xterm is working – unixit May 7 '15 at 7:58
4
+50

I don't think this has to do with fonts. The invisible windows look like a graphics stack problem. Try switching to a non-compositing window manager temporarily, and see if the problem goes away.

Re corrupt files, I'm not sure how they'd get corrupted unless they were being written or replaced during the crash. I suppose font caches and such might be corrupt. But my hunch is that the damaged files are a red herring, and that the source of your problems is a graphics driver bug. (Especially since this is with an Intel integrated GPU of clearly recent vintage.)

3

Sometimes, a reinstall might not work because there may be dependencies that are corrupt, but not reinstalled because the OS thinks they're good.

Try these:

  1. On your invisible terminal, try installing debsums. sudo apt-get install debsums. Then, a visible terminal would really help at this point.

  2. Init the freshly-installed package. sudo debsums_init

  3. Then, try getting a visible terminal and run sudo debsums -cs. If you see any file here, they're corrupt.

  4. If you do see corrupt files, or a visible terminal is not an option, directly run:

apt-get install --reinstall $(dpkg -S $(debsums -c) | cut -d : -f 1 | sort -u)

This will reinstall the corrupt package/files, if there are any.

Note: This may/may not help. There are instructions for reinstalling almost all packages, but it's not a full OS reinstall.

  • i got a huge list on running that command. – unixit May 7 '15 at 9:51
  • 1
    Good luck, have fun! – Gene May 7 '15 at 10:15
  • I have updated the output list in question do see – unixit May 7 '15 at 10:31
  • 1
    on restart it broke my whole system and I could not even log to a desktop, had to install ubuntu over mint preserving the home directory, and now its showing the term – unixit May 7 '15 at 21:11
  • 1
    So ... problem solved via "wrecking ball" solution? – Otheus May 13 '15 at 14:05
2

Wait, the terminal text is invisible AND you don't see text in dropdown-boxes from X-Windows widgets?? That sounds like a font problem to me.

You do know you have a console, right? CTL-ALT-F1 should get you there. At least then you have a working, local terminal, one which you can read. (Usually, ALT-F7 gets you back to X, but I can't say for sure on your linux flavor.)

I'm pretty sure it's a font problem, yet a font file was not one of those files that was deemed 'corrupt'. So it could be a font-setting -- like a global font file is missing or is not in the place the system expects it to be. Perhaps someone with more knowledge with your environment has a further hint.

Idea #2: Once you're root at a console, add a new user: useradd joeblow and set their password passwd joeblow and then log in as that user. If you still have font problems, we know it's not a user-specific one, but a global one.

  • Not just the text but also the background too is invisible as can be seen – unixit May 7 '15 at 13:58
  • Last time I saw the question, the screenshots didn't appear for me. Can you get to the console or not? The real console, not the pseudo ones. – Otheus May 13 '15 at 14:03
  • only xterm accessible – unixit May 14 '15 at 7:40
  • how is it possible you cannot get to the real console? Are you not working with a physical PC? – Otheus May 15 '15 at 2:39
2

Looks like compositor in Cinnamon is not working properly, it is probably an issue with your drivers.

Unfortunately, it seems that you can't disable compositing in cinnamon manually: Github issue.

My suggestion is to install some non-compositing wm like openbox and try if this issue will reproduce. Besides, try different drivers. Now you use drivers: intel (unloaded: fbdev,vesa) - you can try removing intel or install different version of them. You can add this ppa and update drivers: link.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.