4

I recently decided to install Debian 8 with the KDE desktop environment. A problem I have been having is shutting down the computer. The computer always restarts even when I tell it to shut down. I end up having to hope I don't mess up my drive encryption and hold down the power button. Is this is a known bug or just me? How can I resolve it? I've searched /var/log/ for any shutdown-related errors but can't find anything that appears related.

Linux version 3.16.0-4-amd64 (debian-kernel@lists.debian.org) (gcc version 4.8.4 (Debian 4.8.4-1) ) #1 SMP Debian 3.16.7-ckt9-3 (2015-04-23)

UPDATES:

I've since learned how to enable systemd logging thanks to /usr/share/doc/systemd/README.Debian, but it only seems to log start up events and not shut down. It always restarts instead of shutting down.


I get the same results when I use sudo shutdown -h now via the command line, the system reboots rather than shut down.


I attempted to boot into single user mode and shutdown from there as well. When I enter single user mode, I have the following messages/errors:

bash: cannot set terminal process group (-1): Inappropriate ioctl for device
bash: no job control in this shell

When I run shutdown -h now I then get this error and nothing happens:

Failed to talk to init daemon.

If I just try shutdown I get this error:

Failed to talk to shutdownd, proceeding with immediate shutdown:
No such file or directory
  • check in /var/log/messages – Romeo Ninov May 5 '15 at 4:47
  • I did, I checked messages, kern.log, and syslog. – Dan May 5 '15 at 4:49
  • I even grepped for 'shutdown' and found no results – Dan May 5 '15 at 4:55
  • 2
    It turns out this is a known kernel bug for my make and model of laptop. – Dan May 13 '15 at 8:06
2

I've searched /var/log/ for any shutdown-related errors

Debian 8 using systemd, you should check ERR log with journalctl -xb


The release news says:

"Jessie" ships with a new default init system, systemd. The systemd suite provides many exciting features such as faster boot times, cgroups for services, and the possibility of isolating part of the services. The sysvinit init system is still available in "Jessie".

I am confused It would say No journal files were found.
You can check whether systemd-journald is running withsystemctl status systemd-journald And start it with:

systemctl enable systemd-journald
systemctl start systemd-journald
  • I tried that and got Failed to parse boot descriptor 'x'. Running it with each parameter separately shows No journal files were found. – Dan May 5 '15 at 12:32
  • My fault, That's should be journalctl -xb, which -b results this boot's log and -x offer explanation texts from message catalog. – Jiahao D. May 6 '15 at 1:53
  • It says it is running/active, but running journalctl -xb produces No journal files were found. – Dan May 8 '15 at 18:09
  • It's saying no persistent journal because it's not enabled; see /usr/share/doc/systemd/README.Debian – derobert May 8 '15 at 20:58
  • @derobert I have now enabled logging, but it only appears to log when starting up, there is nothing related to shutting down. Ideas? – Dan May 8 '15 at 22:12
2

This is a known bug affecting HP EliteBook laptops:

  • Bug#775519: System reboots instead of shutting down on HP EliteBook 840
  • Bug#775812: base: HP EliteBook 840 G1 laptop fails to halt/poweroff after 15/12/2015 upgrade

The bug appears to be in the kernel and as such affects other distributions as well.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.