1

I'm enrolled in a linux class right now and one of our assignments was to make a bootable flash drive. My friend is also in this class but he didnt know how to do it so I just made one for him. It was an extra credit assignment so thats why he doesnt know how to do it. He never learned.

So I made 2 bootable drives using my personal computer. I tested them, they both boot. However, when we got to school we had to boot into the flash drive and show the teacher that they worked. I booted into my flash drive and it worked. My friend booted into his flash drive and it didnt work. So I booted into my flash drive because my teacher said if you show me that he has a linux filesystem on his flash drive then he gets points. So I plugged his flash drive while booted into my flash drive. Ubuntu wouldnt recognize it. I opened gparted and gparted listed my flash drive and the computer hdd. Not my friends flash drive. Then I booted into windows and ran diskpart to see all the available disks. It showed my flash drive and the windows hdd. Not his. Then I downloaded a program that lets you view linux partitions in windows. That didnt recognize his drive either.

Windows nor Ubuntu would recognize his flash drive at all. Neither would the BIOS. It cant be a broken usb port because it recognized my drive. So I thought his usb must be corrupt. Well I went home and tried his flash drive on my machine. It booted perfectly fine into Ubuntu.

So I dont see why my drive boots at school and his doesn't, but both of our drives boot on my computer.

Boot from usb is enabled in the bios at school. Both boot drives were made using my computer. Both drives are provided from my school so they're essentially identical. Both drives work on my machine. Both drives were made using the same ISO file and the same iso to usb program with the exact same settings. And yet only one works at school. And also, my computer at school wasn't working so I used his computer to show that my flash drive worked. So we both used the same machine and the same usb port.

edit: yes I tried the obvious by restarting the computer and unplugging it and plugging it back in and even trying a different usb port.

  • This is strange. Maybe it has got something to do with UEFI being installed on the School PC instead of the BIOS. It causes trouble sometimes. But the real mystery is that why one Pendrive is booting while the other is not. – shivams May 5 '15 at 5:01
  • do you suffer the same problems with a other system (windows, fedora, debian,...)? -- are the flash drives identical? or from the same manufacturer? – DJCrashdummy May 5 '15 at 5:44
  • Can you give more info like: what is the size of the drives. When you plug at home both drives, what does the partition table tells you? what about the filesystem types? – BitsOfNix May 5 '15 at 11:51
  • It must be Karma—he didn't do the assignment and you did. :P You could at least have taught him to make the bootable flash drive instead of just doing it for him. – Wildcard Mar 15 '16 at 19:12
  • This sounds like bad hardware or hardware incompatibility. Windows should have recognised the drive even without being able to read it. Likewise the bios should recognise it. In other words it could just be that usb stick. – Philip Couling Jun 24 at 7:52
0

Identical flash drives? Some years ago I had a 2 gB flash drive that I could not make boot, I thought I was doing something wrong, but the identical steps on another UFD did make a bootable drive .. I tried more than 1 method, Unetbootin and grub I think

0

Eventhough the whole story sounds kind of weird (usb should be visible with fdisk -l for instance), I have come across problems trying to boot usb 3.0 pendrives in old machines. While USB 2.0 devices boot on those machines without any problem new devices doesn't. So the question is... is your USB 2.0 and his 3.0? If that is the case and your school's computers are a bit old that is most probably the answer to your question.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.