2

I have two backlight devices in /sys/class/backlight: toshiba and intel_backlight. The former works only before I put my laptop on sleep and the latter works perfectly.

/sys/class/backlight/toshiba/type = "platform" while /sys/class/backlight/intel_backlight/type = "raw".

Gnome 3.16 is somehow using the former even though I have the following /etc/X11/xorg.conf.d/20-intel.conf file:

Section "Device"
    Identifier "card0"
    Driver "intel"
    Option "Backlight" "intel_backlight"
    BusID "PCI:0:2:0"
EndSection

I'm trying to find a workaround (I already posted a bug report). Is it possible to eliminate the toshiba device altogether without breaking acpi or other functionality?

I'm using Arch linux with latest kernel (4.0.1) but the problem is present even with the lts kernel (3.14).

  • A starting point could be the different workarounds proposed by ubuntu kernel backlight debugging page. Tested some once for a similar problem, but finding the right fix is tough. – Vincent Nivoliers May 4 '15 at 9:18
  • I consulted that site and I know what works but Gnome doesn't seem to know the same and therefore I'm trying to remove that choice by leaving just one backlight device. – To Do May 4 '15 at 9:48
  • That's what the kernel boot options in the "Disabling the ACPI backlight driver" section are intended for. Do you still have two entries when setting these boot parameters ? – Vincent Nivoliers May 4 '15 at 15:27
  • Yes, If I remove the acpi_backlight=vendor parameter I get a third device acpi_video0 linked to toshiba (same values). – To Do May 4 '15 at 16:26

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.