1

NetworkManager appears to be running, however cannot connect to router. I am in my first days of using a new computer with a then newly loaded opensuse 13.2. The first few days all appeared to function properly (I really do not know for sure) or at least without error messages. So this problem is probably due to something I did. In the effort to solve this I loaded several other live CD linux distros and the network still did not connect. Changed cables between router and pc. Reset router. Connection to router with old notebook pc is successful. Using YaST2 and selecting, Network Devices, returns this warning: Network is currently handled by NetworkManager or completely disabled...

OS version Linux 3.16.7.21-desktop openSUSE (Harlequin)(x86_64) KDE 4.14.6 motherboard Gigabyte H97-HD3

New info. 2015-05-08.
If I understand correctly, ifconfig is not telling me about the ethernet card so there is no name at this point.

linux-mi46:~ # ifconfig  
lo        Link encap:Local Loopback  
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:65536  Metric:1

          RX packets:328 errors:0 dropped:0 overruns:0 frame:0
          TX packets:328 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0 
          RX bytes:26876 (26.2 Kb)  TX bytes:26876 (26.2 Kb)  

More Info. 2015-05-09.

A closer look following certain advice:
the result of, yast -- kdesu /sbin/yast2 lan, "global options", shows the "network setup method" as "NetworkManager service". And "Overview," shows the Ethernet Network Card DHCP eth0. Started automatically at boot. Do not know if that configuration is correct. None the less continuing...

The command "systemctl status NetworkManager.service" output the following:

linux-mi46:~ # systemctl status NetworkManager.service
NetworkManager.service - Network Manager
Loaded: loaded (/usr/lib/systemd/system/NetworkManager.service; enabled)
Active: active (running) since Sat 2015-05-09 19:30:36 CEST; 55min ago
Main PID: 1086 (NetworkManager)
CGroup: /system.slice/NetworkManager.service
       └─1086 /usr/sbin/NetworkManager --no-daemon

May 09 19:30:36 linux-mi46 NetworkManager[1086]: <info> WiMAX enabled by radio killswitch; enabled by state file
May 09 19:30:36 linux-mi46 NetworkManager[1086]: <info> Networking is enabled by state file
May 09 19:30:36 linux-mi46.site NetworkManager[1086]: <info> Setting system hostname to 'linux-mi46.site' (from syst...ion)
May 09 19:30:36 linux-mi46.site NetworkManager[1086]: <info> (lo): link connected
May 09 19:30:36 linux-mi46.site NetworkManager[1086]: <info> (lo): carrier is ON
May 09 19:30:36 linux-mi46.site NetworkManager[1086]: <info> (lo): new Generic device (driver: 'unknown' ifindex: 1)
May 09 19:30:36 linux-mi46.site NetworkManager[1086]: <info> (lo): exported as /org/freedesktop/NetworkManager/Devices/0
May 09 19:30:36 linux-mi46.site NetworkManager[1086]: <info> startup complete                                              
May 09 19:30:36 linux-mi46.site NetworkManager[1086]: <info> ModemManager available in the bus                             
May 09 19:30:39 linux-mi46.site NetworkManager[1086]: <info> use BlueZ version 5      

New info 2015-05-22.
The command ifconfig was not telling me about the ethernet card because I had disabled the network card in the BIOS. It was only after reinstalling the OS and seeing the same ifconfig result that I looked more closely at my settings in the BIOS. New lesson learned.

  • please post the output of ifconfig and ethtool enp0s1 where enp0s1 is the name of your card. – SailorCire May 4 '15 at 18:42
  • Oh, I see what is wrong, but I don't know how to help. Your output of ifconfig shows all of the network devices reported. You are only showing lo a loop back device. I don't have enough wisdom how to fix this, but look at the entries in /etc/udev/rules.d/70-persistent-net.rules or in /proc/sys/net/ipv4/conf/. You may need to create a new file in /etc/sysconfig/network based on that result. Then again, you're using nework manager so I don't know where the files are stored, but it should still go through udev – SailorCire May 9 '15 at 19:49
  • I'm smiling. I see too. But my smattering of knowledge.and curiosity got me into this and it'll get me out. With some help from people like you and some rereading and trial& error. It an opportunity. Thaks. – WmRobt May 9 '15 at 22:32
  • This makes sense. Recovered previous BIOS setting. A0K – WmRobt May 20 '15 at 6:42
0

This is a case where only a closer look could provide a certain answer. So, this is a little bit of a troubleshooting:

First thing, check yast -- kdesu /sbin/yast2 lan. Go to "global options", check if the "network setup method" is set to "NetworkManager service". Then go back to Overview, check if your NICs appear and if their configuration is correct.

Then, check if NetworkManager is running -- systemctl status NetworkManager.service. If it's not running, run sudo systemctl start NetworkManager.service.

If you haven't seen any error to this point, your network interfaces should appear. Or, at least, you might be able to get a specific error message.

  • Thanks for your help. Up to this point I am still not understanding all that I've done. – WmRobt May 9 '15 at 18:42
  • The definitive answer which I despise. Format and clean install. Nonetheless since all of my user-created files are external to the system and program files I have decided to restore even if I loose this opportunity to learn more linux. Thank you for all your help. – WmRobt May 15 '15 at 13:23
  • More information. 2015-05-20 After reseting BIOS the system is just fine. Sometimes the best solutions are the simplest. Thanks to all the members of this forum for the advice and help. I hope that this will help someone else. – WmRobt May 20 '15 at 7:05

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.