5

I am generally quite happy with DPMS screen blanking but for one (rather annoying situation): when playing a game through Wine with a gamepad the screen blanks after a while. I guess that in this case button presses on the gamepad don't get recognised by Xorg (keyboard presses prevent DPMS from activating, as expected).

I know that in this case I could resort to some kind of hack, like a wrapper script that disables DPMS through xset before running wine (and re-enables it afterwards), but I would like to know if there are better solutions.

Note: I am running XMonad on ArchLinux, in case this might be relevant.

2

I use a bash script named lightsOn.sh for preventing dpms and screensaver when watching videos fullscreen. This may also work for you even though you will have to adapt it to detect your game process. But the script is well documented.

See here: https://bbs.archlinux.org/viewtopic.php?id=130447

1

AFAIK, programs that need that (like media players), either disable DPMS/the screensaver by themselves or have options for that behavior. So I'd look for an option in Wine, or go with the wrapper script.

0

I found a guy who wrote a little script called joystickwake. As far as I know, a real solution has been outstanding for years now. It doesn't only affect wine obviously but also native Linux games. It's also an effing disgrace for Linux as a gaming platform.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.